summaryrefslogtreecommitdiff
path: root/sys-fs/dmraid
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /sys-fs/dmraid
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'sys-fs/dmraid')
-rw-r--r--sys-fs/dmraid/Manifest1
-rw-r--r--sys-fs/dmraid/dmraid-1.0.0_rc16-r4.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/sys-fs/dmraid/Manifest b/sys-fs/dmraid/Manifest
index a9c8fe924393..91f54f19a96b 100644
--- a/sys-fs/dmraid/Manifest
+++ b/sys-fs/dmraid/Manifest
@@ -4,4 +4,5 @@ AUX dmraid-1.0.0_rc16-static-build-fixes.patch 3840 BLAKE2B 713e255890dfbfd7ded8
AUX dmraid-1.0.0_rc16-undo-p-rename.patch 531 BLAKE2B eef9d2ef5f2766773bf83bba93d44a02a450a03b1e338f3120473512fe60d7a5f60d4bb2ae25ed019e0c58b89c5e67fd81426ae0fd5e06220976640b84d29d67 SHA512 b5b93d49e716c585284dfd89fe4651fd5bb6921196a053797aeec9cf5654f11da7b2ed1ad93f2df15fd3ef47c95efd67aeecc196fcfd3feb22f7903ad103a8c6
DIST dmraid-1.0.0.rc16-3.tar.bz2 232743 BLAKE2B 290c5bb7f1b12ac48627d8afcc346327b2fcce31b1015d5974c956d94f607b297e383158cd8741f03a770cdeb3f42c3e6341ebfcbc2220e122d89c2603eee512 SHA512 7c45e5117adc52fc2094b1b2bad4f4c518a46317a2196611966d72085ba3587c4ac8d1080f9d934888c01788f2b2d3d621c6f0d3e2a023c0fb1f9f3fa7fc127e
EBUILD dmraid-1.0.0_rc16-r3.ebuild 3267 BLAKE2B 00b1ce94096b42699c028a54e0462e91870bcd7e790ec68fa8d18f21d949f4e2aee9ff88bbce5e191eb7c29e98ef644caef2bd78fe1d27643255506bff36304e SHA512 eca54618444b7e4afa2e69dcb134adcaaaa9a370d43623cc008b6b03e11683839aed8ad2335f60c70b69094e91bdc4eca9f346962d11102ac607c97e06906172
+EBUILD dmraid-1.0.0_rc16-r4.ebuild 3199 BLAKE2B df8cc50e363a354ebbcfa4adbb98b3fac4d4ee23a102950819a4337576a69bc7d8501f73f9fa62f908c8d37220135546b15f1b8329d7179cd6270972ba27e94b SHA512 db1ac9ee6140aae30d3124895d4b8cffb414663449c53f5559a6d76f17d19433057419516c8978fc9b8afea0462f9071695d7042e766c427b08d86bf0432b9f4
MISC metadata.xml 769 BLAKE2B 58eaf54f32d2bdfa2bdcdb149d97a5e23cfaa91edcf261041953b46ca79291dc8f687da56d9fc2c821697fe69cdc54f78515581566c2ab4a5afc125273e4c3a4 SHA512 e716dad80405dae942af5ded092214854432f43a5c622e8ce41f36af3f514c9425de401da278e2b0a2abc96103e4894896ff539f5665e5c48ec2640e57d11e26
diff --git a/sys-fs/dmraid/dmraid-1.0.0_rc16-r4.ebuild b/sys-fs/dmraid/dmraid-1.0.0_rc16-r4.ebuild
new file mode 100644
index 000000000000..153fa71d352a
--- /dev/null
+++ b/sys-fs/dmraid/dmraid-1.0.0_rc16-r4.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools linux-info flag-o-matic eutils
+
+MY_PV=${PV/_/.}-3
+
+DESCRIPTION="Device-mapper RAID tool and library"
+HOMEPAGE="https://people.redhat.com/~heinzm/sw/dmraid/"
+SRC_URI="https://people.redhat.com/~heinzm/sw/dmraid/src/${PN}-${MY_PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="intel_led led mini static"
+
+RDEPEND=">=sys-fs/lvm2-2.02.45"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ static? ( sys-fs/lvm2[static-libs] )
+"
+
+S="${WORKDIR}/${PN}/${MY_PV}/${PN}"
+
+pkg_setup() {
+ if kernel_is lt 2 6 ; then
+ ewarn "You are using a kernel < 2.6"
+ ewarn "DMraid uses recently introduced Device-Mapper features."
+ ewarn "These might be unavailable in the kernel you are running now."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-undo-p-rename.patch \
+ "${FILESDIR}"/${P}-return-all-sets.patch \
+ "${FILESDIR}"/${P}-static-build-fixes.patch \
+ "${FILESDIR}"/${P}-parallel-make.patch
+ # pkg_check_modules is not in aclocal.m4 by default, and eautoreconf doesnt add it
+ einfo "Appending pkg.m4 from system to aclocal.m4"
+ cat "${ROOT}"/usr/share/aclocal/pkg.m4 >>"${S}"/aclocal.m4 || die "Could not append pkg.m4"
+ epatch_user
+ eautoreconf
+
+ einfo "Creating prepatched source archive for use with Genkernel"
+ # archive the patched source for use with genkernel
+ cd "${WORKDIR}" || die
+ mkdir -p "tmp/${PN}" || die
+ cp -a "${PN}/${MY_PV}/${PN}" "tmp/${PN}" || die
+ mv "tmp/${PN}/${PN}" "tmp/${PN}/${MY_PV}" || die
+ cd tmp || die
+ tar -jcf ${PN}-${MY_PV}-prepatched.tar.bz2 ${PN} || die
+ mv ${PN}-${MY_PV}-prepatched.tar.bz2 .. || die
+}
+
+src_configure() {
+ # disable klibc and dietlibc, bug #653392
+ econf --with-usrlibdir='${prefix}'/$(get_libdir) \
+ --disable-klibc \
+ --disable-dietlibc \
+ $(use_enable static static_link) \
+ $(use_enable mini) \
+ $(use_enable led) \
+ $(use_enable intel_led)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc CHANGELOG README TODO KNOWN_BUGS doc/*
+ insinto /usr/share/${PN}
+ doins "${WORKDIR}"/${PN}-${MY_PV}-prepatched.tar.bz2
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "For booting Gentoo from Device-Mapper RAID you can use a Genkernel initramfs."
+ elog
+ elog "Genkernel will generate the kernel and the initramfs with a statically "
+ elog "linked dmraid binary (its own version which may not be the same as this version):"
+ elog "\t emerge -av sys-kernel/genkernel"
+ elog "\t genkernel --dmraid all"
+ fi
+ # skip this message if this revision has already been emerged
+ if [[ " ${REPLACING_VERSIONS} " != *\ ${PVR}\ * ]]; then
+ elog
+ elog "A pre-patched distfile of this version of DMRAID has been installed at"
+ elog "/usr/share/${PN}/${PN}-${MY_PV}-prepatched.tar.bz2 , to support using it within a"
+ elog "Genkernel initramfs."
+ elog
+ fi
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "If you would rather use this version of DMRAID with Genkernel, update the following"
+ elog "in /etc/genkernel.conf:"
+ elog "\t DMRAID_VER=\"${MY_PV}\""
+ elog "\t DMRAID_SRCTAR=\"/usr/share/${PN}/${PN}-${MY_PV}-prepatched.tar.bz2\""
+ elog
+ fi
+}