summaryrefslogtreecommitdiff
path: root/sys-fs/ddrescue/ddrescue-1.28.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-07 18:30:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-07 18:30:54 +0100
commit4d190a87291ace8503ad92c6b049d14660a14c72 (patch)
tree3c46c3d158d4e77a4c12d283a17bade041a9859f /sys-fs/ddrescue/ddrescue-1.28.ebuild
parent3c7931f8c6c90aa813912d87c684d742e0c29a05 (diff)
gentoo auto-resync : 07:04:2024 - 18:30:54
Diffstat (limited to 'sys-fs/ddrescue/ddrescue-1.28.ebuild')
-rw-r--r--sys-fs/ddrescue/ddrescue-1.28.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-fs/ddrescue/ddrescue-1.28.ebuild b/sys-fs/ddrescue/ddrescue-1.28.ebuild
new file mode 100644
index 000000000000..0ba725b13aff
--- /dev/null
+++ b/sys-fs/ddrescue/ddrescue-1.28.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs flag-o-matic unpacker
+
+DESCRIPTION="Copy data from one file or block device to another with read-error recovery"
+HOMEPAGE="https://www.gnu.org/software/ddrescue/ddrescue.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.lz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux"
+IUSE="static"
+
+BDEPEND="$(unpacker_src_uri_depends)"
+
+src_configure() {
+ use static && append-ldflags -static
+
+ # not a normal configure script
+ econf \
+ --prefix="${EPREFIX}"/usr \
+ CXX="$(tc-getCXX)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_test() {
+ ./testsuite/check.sh "${S}"/testsuite || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-man
+ einstalldocs
+}