summaryrefslogtreecommitdiff
path: root/sys-fs/cryptsetup/cryptsetup-2.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /sys-fs/cryptsetup/cryptsetup-2.2.0.ebuild
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'sys-fs/cryptsetup/cryptsetup-2.2.0.ebuild')
-rw-r--r--sys-fs/cryptsetup/cryptsetup-2.2.0.ebuild14
1 files changed, 4 insertions, 10 deletions
diff --git a/sys-fs/cryptsetup/cryptsetup-2.2.0.ebuild b/sys-fs/cryptsetup/cryptsetup-2.2.0.ebuild
index 49cad800b719..8cb062389bc5 100644
--- a/sys-fs/cryptsetup/cryptsetup-2.2.0.ebuild
+++ b/sys-fs/cryptsetup/cryptsetup-2.2.0.ebuild
@@ -13,13 +13,12 @@ LICENSE="GPL-2+"
SLOT="0/12" # libcryptsetup.so version
[[ ${PV} != *_rc* ]] && \
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-# cryptsetup does _not_ have a libressl backend. We only have this for REQUIRED_USE
-# and change "libressl" to "openssl" in our econf call.
-CRYPTO_BACKENDS="gcrypt kernel libressl nettle +openssl"
+CRYPTO_BACKENDS="gcrypt kernel nettle +openssl"
# we don't support nss since it doesn't allow cryptsetup to be built statically
# and it's missing ripemd160 support so it can't provide full backward compatibility
IUSE="${CRYPTO_BACKENDS} +argon2 libressl +luks1_default nls pwquality reencrypt static static-libs +udev urandom"
REQUIRED_USE="^^ ( ${CRYPTO_BACKENDS//+/} )
+ libressl? ( openssl )
static? ( !gcrypt )" #496612
LIB_DEPEND="
@@ -32,7 +31,7 @@ LIB_DEPEND="
nettle? ( >=dev-libs/nettle-2.4[static-libs(+)] )
openssl? (
!libressl? ( dev-libs/openssl:0=[static-libs(+)] )
- libressl? ( dev-libs/libressl:=[static-libs(+)] )
+ libressl? ( dev-libs/libressl:0=[static-libs(+)] )
)
pwquality? ( dev-libs/libpwquality[static-libs(+)] )
sys-fs/lvm2[static-libs(+)]
@@ -83,11 +82,6 @@ src_configure() {
ewarn "userspace crypto libraries."
fi
- local x cryptobackend
- for x in ${CRYPTO_BACKENDS//+/} ; do
- use ${x} && cryptobackend="${x/libressl/openssl}"
- done
-
local myeconfargs=(
--disable-internal-argon2
--enable-shared
@@ -95,7 +89,7 @@ src_configure() {
# for later use
--with-default-luks-format=LUKS$(usex luks1_default 1 2)
--with-tmpfilesdir="${EPREFIX}/usr/lib/tmpfiles.d"
- --with-crypto_backend=${cryptobackend}
+ --with-crypto_backend=$(for x in ${CRYPTO_BACKENDS//+/} ; do usev ${x} ; done)
$(use_enable argon2 libargon2)
$(use_enable nls)
$(use_enable pwquality)