summaryrefslogtreecommitdiff
path: root/sys-fs/cryptmount
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-26 12:00:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-26 12:00:09 +0100
commitf300354de9fe5d997850456a9e1f400193e6544f (patch)
tree402fd6a7727db790bf57f683894052e8791d389e /sys-fs/cryptmount
parent5c42677148c717eb9f4673237db807f74740b4e9 (diff)
gentoo auto-resync : 26:08:2024 - 12:00:09
Diffstat (limited to 'sys-fs/cryptmount')
-rw-r--r--sys-fs/cryptmount/Manifest4
-rw-r--r--sys-fs/cryptmount/cryptmount-6.3.0.ebuild72
-rw-r--r--sys-fs/cryptmount/metadata.xml1
3 files changed, 76 insertions, 1 deletions
diff --git a/sys-fs/cryptmount/Manifest b/sys-fs/cryptmount/Manifest
index 34d98a21f297..318a27eefdc6 100644
--- a/sys-fs/cryptmount/Manifest
+++ b/sys-fs/cryptmount/Manifest
@@ -1,3 +1,5 @@
DIST cryptmount-6.2.0.tar.gz 548497 BLAKE2B 45602d86624464c8c1c2ad9cf3ffc4bf311d60ae16c2294111b1fc98bb0e02952c69c767a1c583428c3d8eb0ade2caddb17d3187f4dd34d780772b299ea1a6c0 SHA512 005d9333792a567515ce6d487d2dfa18f19cb077a64d9c356562acefc1947581d2d0f584ad623e0aab8aed1b34f1614af3a42f0c582d31e0831cdb8eb22bb7ce
+DIST cryptmount-6.3.0.tar.gz 373196 BLAKE2B b59127f9944f4bf267d4272bc026909b704f474b2fd2a20baf9125f9b32b33ecfd5523c6ef05098e6467e9b7e938daba55685dc47a3317a4913aef4c517f66f2 SHA512 15f19a1ff7409b35be2cde3d791c8d476c98ffcaf3dd9217076703b0e0baafe999a0608a88cc51039ba2e9c26cb297261128a5efeacd1a6397c5d3300886ac4d
EBUILD cryptmount-6.2.0.ebuild 1646 BLAKE2B 7fa9fb2c8c0204636f1dd55ef59f9ae46fe31ecad2fcf7eef69c8b178dc1e1f9fc9fc55a1f82ec042eae4d8847809feb252ea7d486b9eef32c3fd10006d13100 SHA512 0665a0e0ddd46f74f8cef513c346cd421b389e015b92b714dee203282aaa3cf915a4ede17d9d41285568c057359a256bbb0c385baf74af17b5809bfa355b88a8
-MISC metadata.xml 2146 BLAKE2B 9547e66f62ddf51455e742a6c6f5b350eb8cb4ff62cc4f605607f8970714587758dff8e9437d355e1781a2ce2e25e38e184730de0c39cd5d191b8459bc540c3a SHA512 09d3385123051712f2a264f5c2793f1d99090ed095af17b4753ad925f73e0af85c355fc985966f7fc3cb8b8225dbb9fab23e254308d29633a73bcb6173dde029
+EBUILD cryptmount-6.3.0.ebuild 1579 BLAKE2B 6773177137074568c40662a5b5cad1f576abaa857a56d0013fc2248e70969f28e6d04306e96fc81f34061064abbb13be8791184c15826fcfa5383a66bb89466b SHA512 88889b4adbed8ae15e8c6448670a2ea4f78a34f512dd47af9870f00c11d0c5995a6f173530924422d133083bb2cf8be275927550de7a9b7e29847d40c53ef54b
+MISC metadata.xml 2205 BLAKE2B e8db36615800db96d3857ad16f4daaccbc1354c3aa1c55f2385b07a6abe9831a0bb691672a452291ede20ea0ed4a49de26e7e45417297a37436273fdcf17c01b SHA512 631f74f0e6c1e83a0471595db1b63604d785410f1f0fc684ddd8114ea29ea42a24dd42251b0618685e376b8b7b910eee42211938494d95164cc0e5ce392c27e4
diff --git a/sys-fs/cryptmount/cryptmount-6.3.0.ebuild b/sys-fs/cryptmount/cryptmount-6.3.0.ebuild
new file mode 100644
index 000000000000..b03b2950fe73
--- /dev/null
+++ b/sys-fs/cryptmount/cryptmount-6.3.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools linux-info
+
+DESCRIPTION="A utility for management and user-mode mounting of encrypted filesystems"
+HOMEPAGE="http://cryptmount.sourceforge.net/"
+SRC_URI="https://github.com/rwpenney/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="argv0switch cswap fsck +gcrypt +largefile mount +nls +luks +openssl systemd"
+REQUIRED_USE="
+ luks? ( gcrypt )
+ openssl? ( gcrypt )
+"
+
+RDEPEND="
+ sys-fs/lvm2
+ virtual/libiconv
+ virtual/libintl
+ gcrypt? ( dev-libs/libgcrypt:0= )
+ luks? ( sys-fs/cryptsetup )
+ openssl? ( dev-libs/openssl:0= )
+ systemd? ( sys-apps/systemd )
+"
+
+DEPEND="
+ ${RDEPEND}
+ sys-kernel/linux-headers
+"
+
+BDEPEND="nls? ( sys-devel/gettext )"
+
+CONFIG_CHECK="BLK_DEV_DM"
+ERROR_BLK_DEV_DM="
+ Please enable Device Mapper support in your kernel config
+ -> Device Drivers
+ -> Multiple devices driver support (RAID and LVM)
+ -> Multiple devices driver support (RAID and LVM)
+ <*>/<M> Device mapper support
+"
+
+src_prepare() {
+ default
+
+ # Fix doc directory
+ sed -e 's/doc\/cryptmount/doc\/${PF}/g' -i Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconf=(
+ --disable-rpath
+ $(use_enable argv0switch)
+ $(use_enable cswap)
+ $(use_enable fsck)
+ $(use_with gcrypt libgcrypt)
+ $(use_enable largefile)
+ $(use_enable mount delegation)
+ $(use_enable nls)
+ $(use_enable luks)
+ $(use_enable openssl openssl-compat)
+ $(use_with systemd)
+ )
+
+ econf "${myeconf[@]}"
+}
diff --git a/sys-fs/cryptmount/metadata.xml b/sys-fs/cryptmount/metadata.xml
index 04afce0bebc0..36c2b7762024 100644
--- a/sys-fs/cryptmount/metadata.xml
+++ b/sys-fs/cryptmount/metadata.xml
@@ -34,6 +34,7 @@
</use>
<upstream>
<bugs-to>https://sourceforge.net/p/cryptmount/bugs/</bugs-to>
+ <remote-id type="github">rwpenney/cryptmount</remote-id>
<remote-id type="sourceforge">cryptmount</remote-id>
</upstream>
</pkgmetadata>