summaryrefslogtreecommitdiff
path: root/sys-fs/cryptmount
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-21 20:47:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-21 20:47:17 +0000
commit4ab6db5717ef23f29320d4c6fb9ebdb8dec1f193 (patch)
treef7640b8b96a04499f1ce44a2cad122d45a8373bd /sys-fs/cryptmount
parent48bdeb0db9c7ffed22c6eb859ee40b55ba598b86 (diff)
gentoo resync : 21.12.2017
Diffstat (limited to 'sys-fs/cryptmount')
-rw-r--r--sys-fs/cryptmount/Manifest1
-rw-r--r--sys-fs/cryptmount/cryptmount-5.2.2-r1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/sys-fs/cryptmount/Manifest b/sys-fs/cryptmount/Manifest
index 0d380317f767..cac643b5c6b6 100644
--- a/sys-fs/cryptmount/Manifest
+++ b/sys-fs/cryptmount/Manifest
@@ -1,3 +1,4 @@
DIST cryptmount-5.2.2.tar.gz 743638 BLAKE2B fdcf0ec18904bd847d905a1241c0e4e9c825b9c73f2cab0406426d56d22a0ef4d26701d9955b4f7975cc1cedcd650758cd4aebb29805e6cf8a8c05ef9202b8b7 SHA512 e8767728c49b7f8dc4f777778d5a9d1b912ea2c4c5363dbb5035a208aa1bd1f2565ce12a0666d75e9ee677bde04029082d20c22cf46a216f5e87a4adf7093572
+EBUILD cryptmount-5.2.2-r1.ebuild 1134 BLAKE2B 7540b21b4bff4363d7b104ca0ddf71ef3c5339747b5401596aa75ca76f76fd1b19d750c8cb00062ce20e5aa6888798b7501d59bfd57d70caed06edfe8a607269 SHA512 5bbca0cb292b45cc01143343cf87adddb15be390b1e1681b27b55dee01d2827bae57a040b959d704ee49ea16a775548778e76d3eefa1994f5a09205e73981f3e
EBUILD cryptmount-5.2.2.ebuild 1118 BLAKE2B 598a04d8f3a7b37a235f7157f55411697d4df916da320046e2b839ec17fdff5580c715d69edf95414f17f86adb71cc9b8c8e049c1df55ffca7cae3afb10d7ab8 SHA512 5746a3eb8cee6c46f8ec86c7ace69b0fde7ef48c744c4c567512fac5bb8da0d71817de302d38aecaee8314968f9ec953f8f3e830927fe6cdd971fa95e4e05f51
MISC metadata.xml 416 BLAKE2B 7a938bffedc5fed996fc17255dde34c60f340c7a325456a2fca129ebf19dbcacd3b688908e3f02ae34ff54f823aa87fa0f3529f4132198fef742cfe4f63b83c1 SHA512 aed33cb7b5205b2227109d99dd96dd341386406079ddf2a1583c0998215183ab3460160a33f2dfe6fb673236e37a061f7d41273e978b58081d787175fb5f8840
diff --git a/sys-fs/cryptmount/cryptmount-5.2.2-r1.ebuild b/sys-fs/cryptmount/cryptmount-5.2.2-r1.ebuild
new file mode 100644
index 000000000000..690f70da85bb
--- /dev/null
+++ b/sys-fs/cryptmount/cryptmount-5.2.2-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info systemd
+
+DESCRIPTION="A utility for management and user-mode mounting of encrypted filesystems"
+HOMEPAGE="http://cryptmount.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="nls +ssl systemd"
+
+DOCS=( AUTHORS ChangeLog NEWS README RELNOTES ToDo )
+
+RDEPEND="
+ dev-libs/libgcrypt:0=
+ sys-fs/lvm2:0=
+ nls? ( virtual/libintl )
+ ssl? ( dev-libs/openssl:0= )
+ systemd? ( sys-apps/systemd )"
+
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+CONFIG_CHECK="BLK_DEV_DM"
+ERROR_BLK_DEV_DM="Please enable Device mapper support in your kernel config
+ -> Device Drivers
+ -> Multi-device support (RAID and LVM)
+ -> Multiple devices driver support (RAID and LVM) (MD)
+ <M> Device mapper support"
+
+src_configure() {
+ econf \
+ --enable-cswap \
+ --enable-delegation \
+ --enable-fsck \
+ --enable-luks \
+ --with-libgcrypt \
+ $(use_enable nls) \
+ $(use_enable ssl openssl-compat) \
+ $(use_with systemd)
+}
+
+src_install() {
+ default
+}