summaryrefslogtreecommitdiff
path: root/sys-fs/btrfs-progs/btrfs-progs-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
commit2018227e9344edb9da15fc6a4a8298086cc2aa77 (patch)
treec18e1c09e605e94e2a1e93345ad25746cc9e14b9 /sys-fs/btrfs-progs/btrfs-progs-9999.ebuild
parent6f8038813c460b4f0572d5ef595cdfa94af3a94d (diff)
gentoo resync : 02.06.2019
Diffstat (limited to 'sys-fs/btrfs-progs/btrfs-progs-9999.ebuild')
-rw-r--r--sys-fs/btrfs-progs/btrfs-progs-9999.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/sys-fs/btrfs-progs/btrfs-progs-9999.ebuild b/sys-fs/btrfs-progs/btrfs-progs-9999.ebuild
index 4076d30d2382..4680b387969c 100644
--- a/sys-fs/btrfs-progs/btrfs-progs-9999.ebuild
+++ b/sys-fs/btrfs-progs/btrfs-progs-9999.ebuild
@@ -27,7 +27,7 @@ HOMEPAGE="https://btrfs.wiki.kernel.org"
LICENSE="GPL-2"
SLOT="0/${libbtrfs_soname}"
-IUSE="+convert python reiserfs static static-libs +zstd"
+IUSE="+convert doc python reiserfs static static-libs +zstd"
RESTRICT=test # tries to mount repared filesystems
@@ -63,9 +63,11 @@ DEPEND="${RDEPEND}
)
"
BDEPEND="
- >=app-text/asciidoc-8.6.0
- app-text/docbook-xml-dtd:4.5
- app-text/xmlto
+ doc? (
+ || ( >=app-text/asciidoc-8.6.0 dev-ruby/asciidoctor )
+ app-text/docbook-xml-dtd:4.5
+ app-text/xmlto
+ )
"
if [[ ${PV} == 9999 ]]; then
@@ -95,6 +97,7 @@ src_configure() {
local myeconfargs=(
--bindir="${EPREFIX}"/sbin
$(use_enable convert)
+ $(use_enable doc documentation)
$(use_enable elibc_glibc backtrace)
$(use_enable python)
$(use_enable static-libs static)
@@ -116,4 +119,7 @@ src_install() {
emake V=1 DESTDIR="${D}" install "${makeargs[@]}"
newbashcomp btrfs-completion btrfs
use python && python_optimize
+
+ # install prebuilt subset of manuals
+ use doc || doman Documentation/*.[58]
}