summaryrefslogtreecommitdiff
path: root/sys-fs/bees/bees-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /sys-fs/bees/bees-9999.ebuild
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'sys-fs/bees/bees-9999.ebuild')
-rw-r--r--sys-fs/bees/bees-9999.ebuild45
1 files changed, 23 insertions, 22 deletions
diff --git a/sys-fs/bees/bees-9999.ebuild b/sys-fs/bees/bees-9999.ebuild
index 0bfb2654d893..6c38f7b9c91e 100644
--- a/sys-fs/bees/bees-9999.ebuild
+++ b/sys-fs/bees/bees-9999.ebuild
@@ -1,19 +1,19 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit linux-info
+inherit linux-info systemd
DESCRIPTION="Best-Effort Extent-Same, a btrfs dedup agent"
HOMEPAGE="https://github.com/Zygo/bees"
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/Zygo/bees.git"
+if [[ ${PV} == 9999 ]] ; then
inherit git-r3
+ EGIT_REPO_URI="https://github.com/Zygo/bees.git"
else
SRC_URI="https://github.com/Zygo/bees/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
+ KEYWORDS="~amd64 ~arm64"
fi
LICENSE="GPL-3"
@@ -29,14 +29,11 @@ RDEPEND="${DEPEND}"
CONFIG_CHECK="~BTRFS_FS"
ERROR_BTRFS_FS="CONFIG_BTRFS_FS: bees does currently only work with btrfs"
+PATCHES=( "${FILESDIR}/0001-HACK-musl-does-not-define-pthread_getname_np.patch" )
+
pkg_pretend() {
if [[ ${MERGE_TYPE} != buildonly ]]; then
- if kernel_is -lt 4 4 3; then
- ewarn "Kernel versions below 4.4.3 lack critical features needed for bees to"
- ewarn "properly operate, so it won't work. It's recommended to run at least"
- ewarn "kernel version 4.11 for best performance and reliability."
- ewarn
- elif kernel_is -lt 4 11; then
+ if kernel_is -lt 4 11; then
ewarn "With kernel versions below 4.11, bees may severely degrade system performance"
ewarn "and responsiveness. Especially, the kernel may deadlock while bees is"
ewarn "running, it's recommended to run at least kernel 4.11."
@@ -48,7 +45,14 @@ pkg_pretend() {
ewarn "# WARNING: CPU: 3 PID: 18172 at fs/btrfs/backref.c:1391 find_parent_nodes+0xc41/0x14e0"
ewarn
fi
-
+ if kernel_is -lt 5 1 0; then
+ ewarn "IMPORTANT: With kernel versions below 5.1.0, you may experience data corruption"
+ ewarn "due to bees using compression in btrfs. You are adviced to use a chronologically"
+ ewarn "later kernel, that includes older LTS versions released after 5.0.4:"
+ ewarn "Fixed in: 5.1+, 5.0.4+, 4.19.31+, 4.14.108+, 4.9.165+, 4.4.177+, 3.18.137+"
+ ewarn "# commit 8e92821 btrfs: fix corruption reading shared and compressed extents after hole punching"
+ ewarn
+ fi
if kernel_is -lt 5 3 4; then
ewarn "With kernel versions below 5.3.4, bees may trigger a btrfs bug when running"
ewarn "btrfs-balance in parallel. This may lead to meta-data corruption in the worst"
@@ -59,25 +63,22 @@ pkg_pretend() {
ewarn
fi
- if kernel_is -lt 5 0 4; then
- ewarn "IMPORTANT: With kernel versions below 5.0.4, you may experience data corruption"
- ewarn "due to bees using compression in btrfs. You are adviced to use a chronologically"
- ewarn "later kernel, that includes older LTS versions released after 5.0.4:"
- ewarn "Fixed in: 5.1+, 5.0.4+, 4.19.31+, 4.14.108+, 4.9.165+, 4.4.177+, 3.18.137+"
- ewarn "# commit 8e92821 btrfs: fix corruption reading shared and compressed extents after hole punching"
- ewarn
- fi
-
elog "Bees recommends running the latest current kernel for performance and"
elog "reliability reasons, see README.md."
fi
}
+src_prepare() {
+ default
+ sed -i 's/ -Werror//' makeflags || die
+}
+
src_configure() {
cat >localconf <<-EOF || die
LIBEXEC_PREFIX=/usr/libexec
PREFIX=/usr
- LIBDIR=$(get_libdir)
+ LIBDIR="$(get_libdir)"
+ SYSTEMD_SYSTEM_UNIT_DIR="$(systemd_get_systemunitdir)"
DEFAULT_MAKE_TARGET=all
EOF
if [[ ${PV} != "9999" ]] ; then