summaryrefslogtreecommitdiff
path: root/sys-fs/autorun
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-07 03:23:23 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-07 03:23:23 +0000
commitfc0e6a4667fb69a392aa649bf9d6261a30f53373 (patch)
tree81e0142dfcfc0a32ec945aa10dc396ab808c5030 /sys-fs/autorun
parent7842f444601c620f190db9801e59c4f11e686f15 (diff)
gentoo auto-resync : 07:02:2023 - 03:23:23
Diffstat (limited to 'sys-fs/autorun')
-rw-r--r--sys-fs/autorun/Manifest2
-rw-r--r--sys-fs/autorun/files/autorun-3.17-headers.patch44
2 files changed, 44 insertions, 2 deletions
diff --git a/sys-fs/autorun/Manifest b/sys-fs/autorun/Manifest
index 98ed66ec15f1..c8398c8fb951 100644
--- a/sys-fs/autorun/Manifest
+++ b/sys-fs/autorun/Manifest
@@ -1,4 +1,4 @@
-AUX autorun-3.17-headers.patch 229 BLAKE2B 5253f4c30e74baf5ca73235b69e31e5e78db1ed2a5ea829622e880337ae37351397d320577c1d19d6deb8bb4d169e1d36667a9204d3bd22c1708552e3bc242c6 SHA512 6e76e2d2e53bf9af7028bb873957789da1b906290189e82849a47a459449fe7455c19f007491ed5e3b35b97891973c8891d3250f7b559813a5f25ae3ada43225
+AUX autorun-3.17-headers.patch 1087 BLAKE2B fe60a569433249709bc54559df0f82823786b7192c63dc9b7bdfa71da723fe1fae653f7b242160fda0d52d7c1bdf0aafeb1f53f40f207ce0d32ae4c6b4f9c451 SHA512 6a104a93f54c8759a835f460e5228b6551463a007fcd51409a6235f1f99363e33e0c5a4a510a8de8e8fae3a49388e71d45369a4eb595933065aec86a7c246712
DIST autorun-3.17.tar.gz 481168 BLAKE2B 4c217c050c72cfebd04743a5fc99d409c21bfc0f239446a1c0a9901c0a5c7c1523c649f28ae62d00491d34e3b9c5e44cff6b984a97927ec83e5e373d21b8360b SHA512 cb3885fa578616013ec66658c31caa49240b77c10f18c1597d7583d0efa5318c716d8ed468f3387702e94353c0db8c74f202a736278cde563c99d2337cdac11e
EBUILD autorun-3.17.ebuild 490 BLAKE2B b1ae40cadf0ef1b854c78786fc260e63241066ce87e9748ecd32d7356c3116a86c8cd32596714b93a32139b5d8e6cc601e9a3339362426ee17e6d54987ee33bd SHA512 fd37b94f0a121b3a2a9f0c9b3131f166969fbc68c623413ac64eeaec4692fa62d5b876fc9f5bff51869e28e67d100bb6cccce21317a4d5deb063cf21c372ad25
MISC metadata.xml 328 BLAKE2B 9f6629b1e36b400c19333ba991661a8496c645e1bc88bb43a71449791ad8f25235297d93cc6853e2ce132f940ceb5b98d171b88c325d669715e5a1110d94eef0 SHA512 c180a6e200555e2d02ee9dcee44ccd12e9289bfac58e9c2d541c069d535c96f89f7bc97d4d29f9aee22042b24a8c86e78476c029c18a2a5977f39f0fe8d07898
diff --git a/sys-fs/autorun/files/autorun-3.17-headers.patch b/sys-fs/autorun/files/autorun-3.17-headers.patch
index 4fc487d656b3..113367305af0 100644
--- a/sys-fs/autorun/files/autorun-3.17-headers.patch
+++ b/sys-fs/autorun/files/autorun-3.17-headers.patch
@@ -1,5 +1,6 @@
https://bugs.gentoo.org/251684
-
+https://bugs.gentoo.org/875851
+https://bugs.gentoo.org/877125
--- a/autorun.cc
+++ b/autorun.cc
@@ -90,6 +90,8 @@ char *strchr (), *strrchr ();
@@ -11,3 +12,44 @@ https://bugs.gentoo.org/251684
#ifndef MNTTYPE_ISO9660
#define MNTTYPE_ISO9660 "iso9660"
#endif
+--- a/autorun.cc
++++ b/autorun.cc
+@@ -26,20 +26,6 @@
+ #define HAVE_ARGP
+ #endif
+
+-#if STDC_HEADERS
+-# include <string.h>
+-#else
+-# if !HAVE_STRCHR
+-# define strchr index
+-# define strrchr rindex
+-# endif
+-char *strchr (), *strrchr ();
+-# if !HAVE_MEMCPY
+-# define memcpy(d, s, n) bcopy ((s), (d), (n))
+-# define memmove(d, s, n) bcopy ((s), (d), (n))
+-# endif
+-#endif
+-
+ #include <sys/types.h>
+ #if HAVE_SYS_WAIT_H
+ # include <sys/wait.h>
+@@ -78,6 +64,8 @@ char *strchr (), *strrchr ();
+ #include <stdarg.h>
+ #include <mntent.h>
+ #include "cdrom.h"
++#include <cstring>
++#include <climits>
+ #include <list>
+ #include <iostream>
+ #include <libintl.h>
+@@ -88,7 +76,7 @@ char *strchr (), *strrchr ();
+ #include <getopt.h>
+ #endif
+
+-#include <errno.h>
++#include <cerrno>
+
+ #include <stdlib.h>
+