summaryrefslogtreecommitdiff
path: root/sys-fs/aufs-headers/aufs-headers-3.19_p20150323.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-fs/aufs-headers/aufs-headers-3.19_p20150323.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-fs/aufs-headers/aufs-headers-3.19_p20150323.ebuild')
-rw-r--r--sys-fs/aufs-headers/aufs-headers-3.19_p20150323.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-fs/aufs-headers/aufs-headers-3.19_p20150323.ebuild b/sys-fs/aufs-headers/aufs-headers-3.19_p20150323.ebuild
new file mode 100644
index 000000000000..96d6c06c1dae
--- /dev/null
+++ b/sys-fs/aufs-headers/aufs-headers-3.19_p20150323.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit versionator
+
+DESCRIPTION="User space headers for aufs3"
+HOMEPAGE="http://aufs.sourceforge.net/"
+# Clone git://aufs.git.sourceforge.net/gitroot/aufs/aufs3-linux.git
+# Check aufs release Branch
+# Create .config
+# make headers_install INSTALL_HDR_PATH=${T}
+# find ${T} -type f \( ! -name "*aufs*" \) -delete
+# find ${T} -type d -empty -delete
+SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"
+
+src_install() {
+ doheader -r include/*
+}