summaryrefslogtreecommitdiff
path: root/sys-fs/archivemount/archivemount-0.8.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-07 01:33:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-07 01:33:16 +0100
commitc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (patch)
tree3ee550255947da075650f1a551dcc278f9a1b7f8 /sys-fs/archivemount/archivemount-0.8.12.ebuild
parenta978c074e4272bb901fbe4a10de0a7b2af574f17 (diff)
gentoo resync : 07.05.2021
Diffstat (limited to 'sys-fs/archivemount/archivemount-0.8.12.ebuild')
-rw-r--r--sys-fs/archivemount/archivemount-0.8.12.ebuild19
1 files changed, 15 insertions, 4 deletions
diff --git a/sys-fs/archivemount/archivemount-0.8.12.ebuild b/sys-fs/archivemount/archivemount-0.8.12.ebuild
index d987a19f01ed..793dfba16b56 100644
--- a/sys-fs/archivemount/archivemount-0.8.12.ebuild
+++ b/sys-fs/archivemount/archivemount-0.8.12.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit autotools
+
DESCRIPTION="Mount archives using libarchive and FUSE"
HOMEPAGE="https://www.cybernoia.de/software/archivemount.html https://github.com/cybernoid/archivemount"
SRC_URI="https://www.cybernoia.de/software/archivemount/${P}.tar.gz"
@@ -11,7 +13,16 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RDEPEND="app-arch/libarchive:=
+RDEPEND="
+ app-arch/libarchive:=
sys-fs/fuse:0"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # https://bugs.gentoo.org/725998
+ sed -i -e 's/CFLAGS=//g' configure.ac || die
+ eautoreconf
+}