summaryrefslogtreecommitdiff
path: root/sys-firmware
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-11 09:12:41 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-11 09:12:41 +0000
commit343a7272d559a21a0e0ed13cb743fabb2bfcc479 (patch)
treedb03f20672a6244296ccc2aa27e70757937eb9f7 /sys-firmware
parent456dbeaab3e2f71f527eae542ab44d1e372b0655 (diff)
gentoo resync : 11.01.2018
Diffstat (limited to 'sys-firmware')
-rw-r--r--sys-firmware/Manifest.gzbin5042 -> 5038 bytes
-rw-r--r--sys-firmware/intel-microcode/Manifest1
-rw-r--r--sys-firmware/intel-microcode/intel-microcode-20180108-r1.ebuild78
3 files changed, 79 insertions, 0 deletions
diff --git a/sys-firmware/Manifest.gz b/sys-firmware/Manifest.gz
index 1e32a50a9f9b..295d70d12516 100644
--- a/sys-firmware/Manifest.gz
+++ b/sys-firmware/Manifest.gz
Binary files differ
diff --git a/sys-firmware/intel-microcode/Manifest b/sys-firmware/intel-microcode/Manifest
index 6ff660592e6f..57a59958b117 100644
--- a/sys-firmware/intel-microcode/Manifest
+++ b/sys-firmware/intel-microcode/Manifest
@@ -28,5 +28,6 @@ EBUILD intel-microcode-20170707.ebuild 1328 BLAKE2B d895077fb51ed4abcc2b49088ed7
EBUILD intel-microcode-20171117.ebuild 1330 BLAKE2B ce06a3bbba626f8c9c8c0b6c0c9c8e2dbe2063f9cdb4ac984891396bd68d8f1e746b92e3748650a88977ac62baf58b87275d0513158bf6071bc0dabfb92d4bf3 SHA512 f2106b69382b5ff7c1635ea56c68a966a28c9b2a630f9fb07ecf0347c9c5d997b75b1516d85fe14922edcebcdffb30c9a082335b51b732f3c370c72a696be2bd
EBUILD intel-microcode-20171117_p20171215-r1.ebuild 1155 BLAKE2B 12b179939ea6c2e80794f77ad77f0bd6c283b4a9891553283e3c6aab8b2cf73151a19e7f671af802c6b59f51550fed944bf80e0f4c208fa580636ec9541311a8 SHA512 38ca815b1cc6f2bd6f85bf38d1aa7ef544756fee598a5a608e2ffc489dbb24157e78a511e345732162050f62f0615166f60ef0273954048d627003d76b6f5b68
EBUILD intel-microcode-20171117_p20171215.ebuild 1149 BLAKE2B 54add03072f87c0e1083a637d08143dc7457f1164958e5228e9968c762f24f4731a359a44d4eded63ff501faa9df9e3fd90d01131042da53f0fa411d47a53e7d SHA512 298d7d99b7d715abbd64d02f6762186b4fb556e05d9c2adef563c9c5659dee334127ac12e170a39779f466609500c2e74307799b6b8796095356803d3c194696
+EBUILD intel-microcode-20180108-r1.ebuild 2315 BLAKE2B fd3a75a037cfb0c37288ae4f9dfc1de57f34f279516d7bde703ae7cf757571a33c74dd4ec362d97669754ef9959a2ab9f3de131d944039b6d03b05463979008e SHA512 83ba98557be4508e037a2dcdf7079a442712bb0d0ec888e62d3e58cb8b9e06fe7e6a3c1ace7115c22f8262d4bd2c16e09a10336fb3dd792ca2453ee330e57952
EBUILD intel-microcode-20180108.ebuild 1328 BLAKE2B 27e9dfb4283a5ed844514b1fc0df0afe793776454fd9748fd00b68947834465a667b86e9b262a4161d142b42fef80651391fcf872857abaeef66de5492528f3c SHA512 d6a0b50abe64c41bac70172e0672442e46458789ee9fac3df39f91c66f16011f4bd639dcb3cbe236429223d4d51c581ed345e2048bfce205c98a3b05a580839b
MISC metadata.xml 570 BLAKE2B d49b45c4dff6e9116a388c1ab183461f609d31ed2f07c9145847b1cbb30ebf54922fb2474be2947d8668f7dfa5e06f4ac2beb7ab2b39a90976901a16862a3ef9 SHA512 f0c8094b68e2cb452975b01fbdb8c32f031fe1ef26971d518245dd886d2da8ab6c058d61cb4b4b9b1cb56a754cd08c3ef3fa30e280042675fa2d8705874a763e
diff --git a/sys-firmware/intel-microcode/intel-microcode-20180108-r1.ebuild b/sys-firmware/intel-microcode/intel-microcode-20180108-r1.ebuild
new file mode 100644
index 000000000000..60ae099579f5
--- /dev/null
+++ b/sys-firmware/intel-microcode/intel-microcode-20180108-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs mount-boot
+
+# Find updates by searching and clicking the first link (hopefully it's the one):
+# http://www.intel.com/content/www/us/en/search.html?keyword=Processor+Microcode+Data+File
+
+NUM="27431"
+DESCRIPTION="Intel IA32/IA64 microcode update data"
+HOMEPAGE="http://inertiawar.com/microcode/ https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=${NUM}"
+SRC_URI="http://downloadmirror.intel.com/${NUM}/eng/microcode-${PV}.tgz"
+
+LICENSE="intel-ucode"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="initramfs +split-ucode"
+REQUIRED_USE="|| ( initramfs split-ucode )"
+
+DEPEND="sys-apps/iucode_tool"
+RDEPEND="!<sys-apps/microcode-ctl-1.17-r2" #268586
+
+S=${WORKDIR}
+
+# TODO:
+# Blacklist bad microcode here.
+DEFAULT_MICROCODE_SIGNATURES=""
+
+# Advanced users only:
+# merge with:
+# only current CPU: MICROCODE_SIGNATURES="-S"
+# only specific CPU: MICROCODE_SIGNATURES="-s 0x00000f4a -s 0x00010676"
+# exclude specific CPU: MICROCODE_SIGNATURES="-s !0x00000686"
+MICROCODE_SIGNATURES="${MICROCODE_SIGNATURES:=${DEFAULT_MICROCODE_SIGNATURES}}"
+
+pkg_pretend() {
+ if [[ "${MICROCODE_SIGNATURES}" != "${DEFAULT_MICROCODE_SIGNATURES}" ]]; then
+ ewarn "MICROCODE_SIGNATURES is set!"
+ ewarn "The user has decided to install only a SUBSET of microcode."
+ fi
+}
+
+src_install() {
+ # This will take ALL of the upstream microcode sources:
+ # - microcode.dat
+ # - intel-ucode/
+ # In some cases, they have not contained the same content (eg the directory has newer stuff).
+ MICROCODE_SRC=(
+ "${S}"/microcode.dat
+ "${S}"/intel-ucode/
+ )
+ opts=(
+ ${MICROCODE_SIGNATURES}
+ # be strict about what we are doing
+ --overwrite
+ --strict-checks
+ --no-ignore-broken
+ # show everything we find
+ --list-all
+ # show what we selected
+ --list
+ )
+
+ # The earlyfw cpio needs to be in /boot because it must be loaded before
+ # rootfs is mounted.
+ use initramfs && dodir /boot && opts+=( --write-earlyfw="${ED%/}"/boot/intel-uc.img )
+ # split location:
+ use split-ucode && dodir /lib/firmware/intel-ucode && opts+=( --write-firmware="${ED%/}"/lib/firmware/intel-ucode )
+
+ iucode_tool \
+ "${opts[@]}" \
+ "${MICROCODE_SRC[@]}" \
+ || die "iucode_tool ${opts[@]} ${MICROCODE_SRC[@]}"
+
+ dodoc releasenote
+}