summaryrefslogtreecommitdiff
path: root/sys-firmware
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-04 09:13:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-04 09:13:50 +0000
commit0bb8253b38dc8638a46b66ba909c1bfd1054e1ef (patch)
treed408176c81eb4f81d8b3e95a66abc8eedec620e4 /sys-firmware
parent1f709ed82b8014b4c156f87c66cee7d0d1d3905d (diff)
gentoo auto-resync : 04:11:2022 - 09:13:50
Diffstat (limited to 'sys-firmware')
-rw-r--r--sys-firmware/Manifest.gzbin5712 -> 5711 bytes
-rw-r--r--sys-firmware/sof-firmware/Manifest2
-rw-r--r--sys-firmware/sof-firmware/sof-firmware-2.2.2.ebuild33
3 files changed, 35 insertions, 0 deletions
diff --git a/sys-firmware/Manifest.gz b/sys-firmware/Manifest.gz
index f8399261b295..2b9df202881b 100644
--- a/sys-firmware/Manifest.gz
+++ b/sys-firmware/Manifest.gz
Binary files differ
diff --git a/sys-firmware/sof-firmware/Manifest b/sys-firmware/sof-firmware/Manifest
index 62555e63b658..3077d8fdd78d 100644
--- a/sys-firmware/sof-firmware/Manifest
+++ b/sys-firmware/sof-firmware/Manifest
@@ -1,5 +1,7 @@
DIST sof-firmware-2.1.1.tar.gz 4056718 BLAKE2B 0246f6240504d3e8b609b402c41ffe6ed9b8350b6a31c6567851069354e5de5b4ca6d803e78fdde77cdaba7be87c8a8923b2d0fdd0544fd3b28d1e332cd59b63 SHA512 77e9562f67014d78b213fe428edef6a08dcc058a9a762da09a486c002c3aa0b907ea7c8ba6d4f88f5ddab5e564de06df9f2ed77206341a0fe2e1aaab1d9740ce
+DIST sof-firmware-2.2.2.tar.gz 4116116 BLAKE2B e5722242e4b0130086ddb1b12d2adf29254bcae294f3ff49ac07dab3eab75e352a30346dd07c73ac51112b4c5234dc116de81251e01b146328cab673711f1f4c SHA512 6a3be7088f8a93a052563e040a588c600512d08d4b75ae5567db255e334997a6401d41863dcb416562eee07fef0bd2abe1d9d0403cd236ab007474f66271db50
DIST sof-firmware-2.2.tar.gz 4211499 BLAKE2B c0ab39cba3ef3dd19b67d714b5a4e5a6a6cb3e8fb2d290c3fceadeb3f7dd96db986411184e16bca56bdd1905a697f8d416cd4aa5bdff90fe32e96713ff87bb71 SHA512 3cd06f6b8f8d6c3379b987cffa019a0d84263b8e00de40c18516c3e90745d5e150bdf71a8005b1ba704e44bf84d7030195e9c0ebfcd6e35228f4c14e9290cd95
EBUILD sof-firmware-2.1.1-r1.ebuild 898 BLAKE2B 074de783ce38f7f5dba413a40fbdfd46913dc6b1ed16cac2935f721d4a40d5e9313f47127f619d3c66bfafe6a14453ae2077c4f9e7c4005eae1b78488df0ef0e SHA512 dcaea87ffd52b5494c4600a5f7702b1069e7c2c7acb7efec65014f33501f0d8f4027516646b4c610962f019175be7ef7d2bf2c501001df0af9cecd88db8da577
+EBUILD sof-firmware-2.2.2.ebuild 899 BLAKE2B 6510a99bbadde60caad29440742a93c9f31878f65122f428f991efab01e2fbe9c13ffb26dd3e80b19f9b5556536f17e386b58db60d38867846690c7e5bd4f7d2 SHA512 91a698791d36560e74d1bed08fa1bc26f64788985efaa99f9cfd80d9bf6a9c78a29b573ed161d7724a5870e1d55a55150352ade276e4aea2f485d2bff0f0d288
EBUILD sof-firmware-2.2.ebuild 898 BLAKE2B 074de783ce38f7f5dba413a40fbdfd46913dc6b1ed16cac2935f721d4a40d5e9313f47127f619d3c66bfafe6a14453ae2077c4f9e7c4005eae1b78488df0ef0e SHA512 dcaea87ffd52b5494c4600a5f7702b1069e7c2c7acb7efec65014f33501f0d8f4027516646b4c610962f019175be7ef7d2bf2c501001df0af9cecd88db8da577
MISC metadata.xml 218 BLAKE2B b13b149202bf20882c38ce2cfd0e1c4ea9a15f584ff819022fd74261c2f73dc52efe21fe1e621fd84406527ab86bd29147ef34c895ccf9de3596ce58cb59d846 SHA512 068fda6c090090d62a719b26812505efa881b855004ed63dea86b1ee9b698d5d6ccd3210366e7cfa886f886c77e31b90cd69ec015e67286ce0611483304e798f
diff --git a/sys-firmware/sof-firmware/sof-firmware-2.2.2.ebuild b/sys-firmware/sof-firmware/sof-firmware-2.2.2.ebuild
new file mode 100644
index 000000000000..b51c9026bd32
--- /dev/null
+++ b/sys-firmware/sof-firmware/sof-firmware-2.2.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Sound Open Firmware (SOF) binary files"
+HOMEPAGE="https://www.sofproject.org https://github.com/thesofproject/sof https://github.com/thesofproject/sof-bin"
+SRC_URI="https://github.com/thesofproject/sof-bin/releases/download/v${PV}/sof-bin-v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/sof-bin-v${PV}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Needed for sof-ctl
+RDEPEND="media-libs/alsa-lib"
+
+QA_PREBUILT="usr/bin/sof-ctl
+ usr/bin/sof-logger
+ usr/bin/sof-probes"
+
+src_install() {
+ dodir /lib/firmware/intel
+ dodir /usr/bin
+ FW_DEST="${D}/lib/firmware/intel" TOOLS_DEST="${D}/usr/bin" "${S}/install.sh" v${PV} || die
+}
+
+pkg_preinst() {
+ local sofpath="${EROOT}/lib/firmware/intel/sof"
+ if [[ ! -L "${sofpath}" && -d "${sofpath}" ]] ; then
+ rm -r "${sofpath}" || die
+ fi
+}