summaryrefslogtreecommitdiff
path: root/sys-firmware/vgabios/vgabios-0.7a-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /sys-firmware/vgabios/vgabios-0.7a-r1.ebuild
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'sys-firmware/vgabios/vgabios-0.7a-r1.ebuild')
-rw-r--r--sys-firmware/vgabios/vgabios-0.7a-r1.ebuild18
1 files changed, 7 insertions, 11 deletions
diff --git a/sys-firmware/vgabios/vgabios-0.7a-r1.ebuild b/sys-firmware/vgabios/vgabios-0.7a-r1.ebuild
index 081c30ad69c8..aa925da50189 100644
--- a/sys-firmware/vgabios/vgabios-0.7a-r1.ebuild
+++ b/sys-firmware/vgabios/vgabios-0.7a-r1.ebuild
@@ -1,14 +1,12 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
# Can't really call them backports when they're fixes that upstream
# won't carry
FIXES=1
-inherit eutils
-
DESCRIPTION="VGA BIOS implementation"
HOMEPAGE="http://www.nongnu.org/vgabios/"
SRC_URI="https://savannah.gnu.org/download/${PN}/${P}.tgz
@@ -18,16 +16,14 @@ LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
IUSE="binary debug"
-
-DEPEND="!binary? ( sys-devel/dev86 )"
-RDEPEND=""
+BDEPEND="!binary? ( sys-devel/dev86 )"
src_prepare() {
- [[ -n ${FIXES} ]] && \
- EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
- epatch
+ if [[ -n ${FIXES} ]] ; then
+ eapply patches/*.patch
+ fi
- epatch_user
+ default
}
src_compile() {