summaryrefslogtreecommitdiff
path: root/sys-firmware/raspberrypi-wifi-ucode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /sys-firmware/raspberrypi-wifi-ucode
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'sys-firmware/raspberrypi-wifi-ucode')
-rw-r--r--sys-firmware/raspberrypi-wifi-ucode/Manifest1
-rw-r--r--sys-firmware/raspberrypi-wifi-ucode/raspberrypi-wifi-ucode-20210315.3_p5-r1.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/sys-firmware/raspberrypi-wifi-ucode/Manifest b/sys-firmware/raspberrypi-wifi-ucode/Manifest
index 40eaad6544f0..4e90c0a8932c 100644
--- a/sys-firmware/raspberrypi-wifi-ucode/Manifest
+++ b/sys-firmware/raspberrypi-wifi-ucode/Manifest
@@ -1,5 +1,6 @@
DIST firmware-nonfree_20190114-1+rpt11.debian.tar.xz 2038892 BLAKE2B a2d66e637cd26928c23855f5369c13b83e25b6b4353c82e9a62cb14b010a8c1fda566f6d200e0e7a706c7fb140238082238b7af80fe1f75fe3f07c815fc0eb6a SHA512 5ba6783dc3f3903f20321571a1fb2e11d7781de6d49689c68e6e1f194dad9cdddec90abc94a32a130323b2c8f9839af387c46aee895caf30ffb2f6dfe6d95b7d
DIST firmware-nonfree_20210315-3+rpt5.debian.tar.xz 1743300 BLAKE2B 5de090eefc68ba34df43c58a08554891b8e98d1c8ebce37c63275af8ca438b42880d95dcddf902a1491e19007ccab8cec950f74f50c4f84df092c76e6ffb437b SHA512 8a2151b8c96b0ba806eb25fb0eed12c3b3b91d3386f8ed4ab8058dc5c5989ed5eee39c8c24ceaa8f343042a5031a8c4a2cd759b42cb12d76b58209de50c44083
EBUILD raspberrypi-wifi-ucode-20190114.1_p11.ebuild 2379 BLAKE2B 6f3569abe1d0c0071bcd03e7cbed2b45ce7eafdb59a20b793e6a6cb77e70c49c3acb432f2db4727acba3d8b0a2f00a62d7c80a9fc1d83f96940a153d8e8e7979 SHA512 63e2b279a8ca863d7837e6f2d864f4ad3ebb1a1bdb3555415415fb7b92e7739f8623322a41e479a442512df4d967a4ae9b8c04ead4ab1502d72b97873228b7c0
+EBUILD raspberrypi-wifi-ucode-20210315.3_p5-r1.ebuild 2469 BLAKE2B e53483e6971e8a1a71ab50de3011eee09b5df84ed7526617fb7206504b5161860c470db9be1b07c7ccf521c3859cfb12e005443d99b853c0e80f3dc1da4305cd SHA512 8da229dcd2ba62f120abebb9273dcea1d962209082e0fc72d23dc6170d412f42f1f0a8855c69bf961170f6c83669f7ec58cd6ff7a886747da35e1d26cf1e06e1
EBUILD raspberrypi-wifi-ucode-20210315.3_p5.ebuild 2437 BLAKE2B e27c8c4773a6c22bf3270ab969766868ae33ffd579bd593da1598baaf5c3c593442346262d4cc7cffd1420328d08f7f2812b3576a9cbbde63e328216dc040c28 SHA512 adf77ca6d9ee3eec6fad4fbbee2c6e628620d3e0dffec45600011631b3219d40a9b70e948fe145e91283e916faec8f13b3546b8a6a9fa862cc72a07358818b85
MISC metadata.xml 713 BLAKE2B 0440fb00ea20009509c7d0aeb24bb26aa0e982e69457fd7f325aef56f810c448b5776fee4ec4aec58c40e4b895a724e7d0cec605037dea44f19cc487a9b423c3 SHA512 6fbe06d1c2c3913d2d4c40b575b9b0178110184e89be41302a176b15beafa81c7dbc4f755d92fa045210869902b2a37fe5f42bbaae69760c860a63a42d1ab04e
diff --git a/sys-firmware/raspberrypi-wifi-ucode/raspberrypi-wifi-ucode-20210315.3_p5-r1.ebuild b/sys-firmware/raspberrypi-wifi-ucode/raspberrypi-wifi-ucode-20210315.3_p5-r1.ebuild
new file mode 100644
index 000000000000..ce8516611329
--- /dev/null
+++ b/sys-firmware/raspberrypi-wifi-ucode/raspberrypi-wifi-ucode-20210315.3_p5-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Most up-to-date uCode for the Broadcom wifi chips on Raspberry Pi SBCs"
+HOMEPAGE="
+ https://github.com/RPi-Distro/firmware-nonfree
+ https://archive.raspberrypi.org/debian/pool/main/f/firmware-nonfree"
+MY_PN=firmware-nonfree
+SRC_URI="https://archive.raspberrypi.org/debian/pool/main/f/${MY_PN}/${MY_PN}_$(ver_cut 1)-$(ver_cut 2)+rpt$(ver_cut 4).debian.tar.xz"
+S="${WORKDIR}"
+
+LICENSE="Broadcom"
+SLOT="0"
+KEYWORDS="~arm ~arm64"
+
+RDEPEND="
+ net-wireless/wireless-regdb
+ !sys-kernel/linux-firmware[-savedconfig]
+"
+
+pkg_pretend() {
+ local -a BADFILES=()
+ local txt file
+ # /lib/firmware/brcm/brcmfmac434{30,36,55,56}-sdio.*.txt
+ # The above pattern works because the files we want to hit
+ # have names of the form:
+ # * /lib/firmware/brcm/brcmfmac43430-sdio.AP6212.txt
+ # * /lib/firmware/brcm/brcmfmac43430-sdio.Hampoo-D2D3_Vi8A1.txt
+ # * /lib/firmware/brcm/brcmfmac43430-sdio.MUR1DX.txt
+ # * /lib/firmware/brcm/brcmfmac43430-sdio.raspberrypi,3-model-b.txt
+ # * /lib/firmware/brcm/brcmfmac43455-sdio.MINIX-NEO Z83-4.txt
+ # * /lib/firmware/brcm/brcmfmac43455-sdio.raspberrypi,3-model-a-plus.txt
+ # * /lib/firmware/brcm/brcmfmac43455-sdio.raspberrypi,3-model-b-plus.txt
+ # * /lib/firmware/brcm/brcmfmac43455-sdio.raspberrypi,4-model-b.txt
+ # While the files installed by raspberrypi-wifi-ucode have names
+ # of the form:
+ # * /lib/firmware/brcm/brcmfmac43430-sdio.txt
+ # * /lib/firmware/brcm/brcmfmac43436-sdio.txt
+ # * /lib/firmware/brcm/brcmfmac43455-sdio.txt
+ # * /lib/firmware/brcm/brcmfmac43456-sdio.txt
+ # So no overlap is assured.
+ for txt in "${EPREFIX}"/lib/firmware/brcm/brcmfmac434{30,36,55,56}-sdio.*.txt; do
+ [[ -e "${txt}" ]] && BADFILES+=( "${txt}" )
+ done
+
+ if [[ "${#BADFILES[@]}" -gt 1 ]]; then
+ eerror "The following files should be excluded from the savedconfig of"
+ eerror "linux-firmware and linux-firmware should be re-emerged. Even"
+ eerror "though they do not collide with files from ${PN},"
+ eerror "they may be loaded preferentially to the files included in"
+ eerror "${PN}, leading to undefined behaviour."
+ eerror "List of files:"
+ for file in "${BADFILES[@]}"; do
+ eerror "${file}"
+ done
+ fi
+}
+
+src_install() {
+ insinto /lib/firmware/brcm
+ doins debian/config/brcm80211/brcm/*
+
+ insinto /lib/firmware/cypress
+ doins debian/config/brcm80211/cypress/*
+
+ dodoc debian/config/brcm80211/LICENSE debian/changelog
+}