summaryrefslogtreecommitdiff
path: root/sys-firmware/intel-microcode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
commitf78108598211053d41752a83e0345441bb9014ae (patch)
treedd2fc7ae0a1aea7bda4942ab0c453d1e55284b37 /sys-firmware/intel-microcode
parentdc45b83b28fb83e9659492066e347b8dc60bc9e3 (diff)
gentoo resync : 11.02.2018
Diffstat (limited to 'sys-firmware/intel-microcode')
-rw-r--r--sys-firmware/intel-microcode/Manifest1
-rw-r--r--sys-firmware/intel-microcode/intel-microcode-20171117-r1.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/sys-firmware/intel-microcode/Manifest b/sys-firmware/intel-microcode/Manifest
index 960e5f93e62d..869c0da1a38d 100644
--- a/sys-firmware/intel-microcode/Manifest
+++ b/sys-firmware/intel-microcode/Manifest
@@ -25,6 +25,7 @@ EBUILD intel-microcode-20160714.ebuild 1304 BLAKE2B 7c7b3538894f3d0103a1b8069c6a
EBUILD intel-microcode-20161104.ebuild 1302 BLAKE2B 7203e77ba2d5a021d6019863bc8dc15c154913dee0fc005e134304e46092d99d4b6bda185527fedd4367e0c5f2944ac380fd946b4d6bfde19c3620738d01fe1e SHA512 fbe032d5a4db41643a416f6c55dadb50b05e6c94eecd56e418f89a130312eb4de8ff655d6c81b90644ce728399ac1315ff0f62c93a17d11ef5d46c22f4102db3
EBUILD intel-microcode-20170511.ebuild 1302 BLAKE2B d9e27642414d014c5bb6003441f86bb4ce3d07e64dd01f67b8ef962a5b0de6abd5049785a6ea8dfff3ee16be41990d4baadd15093f3a37bdbeb9545e8c0a265e SHA512 4a1fce5bcc5a1d15e2116ea5b9453edaf90326976e7a3c35caecd2fd515087a32755df178f75790c5629952b14aceb3ffd6dff585605eea3812af58eaeac909b
EBUILD intel-microcode-20170707.ebuild 1328 BLAKE2B d895077fb51ed4abcc2b49088ed73dfd9ba6d95790a2cdac193beba937c164e023c26f43c6a7bc7f5ffedd09edafd84382e863195eb6c340e366a3bd51704716 SHA512 163e4553b7411bc9328fce7649eddaed10d07bf6c1adbdfb583bcf8b3680fa4ea8602f4aeeb43b59424ddad96dc1c320d92817a954f8c77f011906284731b7ab
+EBUILD intel-microcode-20171117-r1.ebuild 2590 BLAKE2B 7602d16a960038472d550c8415bc35c8f655bd8677ead95b7e41a3c76ee0f397979a5fae590b32833fb63056f990eb36c266f844797c55d4b7ffc3dfb009563b SHA512 bbb5ba6c3301864dc83973175dee88208ae23afca657ca1a8a988180f6546741d3f84364cf05a12401f1190708a0df1d46250340fd51d10fca0cfa1d08a9d4a8
EBUILD intel-microcode-20171117.ebuild 1330 BLAKE2B ce06a3bbba626f8c9c8c0b6c0c9c8e2dbe2063f9cdb4ac984891396bd68d8f1e746b92e3748650a88977ac62baf58b87275d0513158bf6071bc0dabfb92d4bf3 SHA512 f2106b69382b5ff7c1635ea56c68a966a28c9b2a630f9fb07ecf0347c9c5d997b75b1516d85fe14922edcebcdffb30c9a082335b51b732f3c370c72a696be2bd
EBUILD intel-microcode-20171117_p20171215-r1.ebuild 1155 BLAKE2B 12b179939ea6c2e80794f77ad77f0bd6c283b4a9891553283e3c6aab8b2cf73151a19e7f671af802c6b59f51550fed944bf80e0f4c208fa580636ec9541311a8 SHA512 38ca815b1cc6f2bd6f85bf38d1aa7ef544756fee598a5a608e2ffc489dbb24157e78a511e345732162050f62f0615166f60ef0273954048d627003d76b6f5b68
EBUILD intel-microcode-20171117_p20171215.ebuild 1149 BLAKE2B 54add03072f87c0e1083a637d08143dc7457f1164958e5228e9968c762f24f4731a359a44d4eded63ff501faa9df9e3fd90d01131042da53f0fa411d47a53e7d SHA512 298d7d99b7d715abbd64d02f6762186b4fb556e05d9c2adef563c9c5659dee334127ac12e170a39779f466609500c2e74307799b6b8796095356803d3c194696
diff --git a/sys-firmware/intel-microcode/intel-microcode-20171117-r1.ebuild b/sys-firmware/intel-microcode/intel-microcode-20171117-r1.ebuild
new file mode 100644
index 000000000000..17e267c7816e
--- /dev/null
+++ b/sys-firmware/intel-microcode/intel-microcode-20171117-r1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs mount-boot
+
+# Find updates by searching and clicking the first link (hopefully it's the one):
+# http://www.intel.com/content/www/us/en/search.html?keyword=Processor+Microcode+Data+File
+
+NUM="27337"
+DESCRIPTION="Intel IA32/IA64 microcode update data"
+HOMEPAGE="http://inertiawar.com/microcode/ https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=${NUM}"
+SRC_URI="http://downloadmirror.intel.com/${NUM}/eng/microcode-${PV}.tgz"
+
+LICENSE="intel-ucode"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE="initramfs +split-ucode"
+REQUIRED_USE="|| ( initramfs split-ucode )"
+
+DEPEND="sys-apps/iucode_tool"
+RDEPEND="!<sys-apps/microcode-ctl-1.17-r2" #268586
+
+S=${WORKDIR}
+
+# TODO:
+# Blacklist bad microcode here.
+DEFAULT_MICROCODE_SIGNATURES=""
+
+# Advanced users only:
+# merge with:
+# only current CPU: MICROCODE_SIGNATURES="-S"
+# only specific CPU: MICROCODE_SIGNATURES="-s 0x00000f4a -s 0x00010676"
+# exclude specific CPU: MICROCODE_SIGNATURES="-s !0x00000686"
+MICROCODE_SIGNATURES="${MICROCODE_SIGNATURES:=${DEFAULT_MICROCODE_SIGNATURES}}"
+
+pkg_pretend() {
+ if [[ "${MICROCODE_SIGNATURES}" != "${DEFAULT_MICROCODE_SIGNATURES}" ]]; then
+ ewarn "MICROCODE_SIGNATURES is set!"
+ ewarn "The user has decided to install only a SUBSET of microcode."
+ fi
+ use initramfs && mount-boot_pkg_pretend
+}
+
+src_install() {
+ # This will take ALL of the upstream microcode sources:
+ # - microcode.dat
+ # - intel-ucode/
+ # In some cases, they have not contained the same content (eg the directory has newer stuff).
+ MICROCODE_SRC=(
+ "${S}"/microcode.dat
+ "${S}"/intel-ucode/
+ )
+ opts=(
+ ${MICROCODE_SIGNATURES}
+ # be strict about what we are doing
+ --overwrite
+ --strict-checks
+ --no-ignore-broken
+ # show everything we find
+ --list-all
+ # show what we selected
+ --list
+ )
+
+ # The earlyfw cpio needs to be in /boot because it must be loaded before
+ # rootfs is mounted.
+ use initramfs && dodir /boot && opts+=( --write-earlyfw="${ED%/}"/boot/intel-uc.img )
+ # split location:
+ use split-ucode && dodir /lib/firmware/intel-ucode && opts+=( --write-firmware="${ED%/}"/lib/firmware/intel-ucode )
+
+ iucode_tool \
+ "${opts[@]}" \
+ "${MICROCODE_SRC[@]}" \
+ || die "iucode_tool ${opts[@]} ${MICROCODE_SRC[@]}"
+
+ dodoc releasenote
+}
+
+pkg_preinst() {
+ use initramfs && mount-boot_pkg_preinst
+}
+
+pkg_prerm() {
+ use initramfs && mount-boot_pkg_prerm
+}
+
+pkg_postrm() {
+ use initramfs && mount-boot_pkg_postrm
+}
+
+pkg_postinst() {
+ use initramfs && mount-boot_pkg_postinst
+}