summaryrefslogtreecommitdiff
path: root/sys-firmware/b43legacy-firmware/b43legacy-firmware-3.130.20.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-firmware/b43legacy-firmware/b43legacy-firmware-3.130.20.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-firmware/b43legacy-firmware/b43legacy-firmware-3.130.20.0.ebuild')
-rw-r--r--sys-firmware/b43legacy-firmware/b43legacy-firmware-3.130.20.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-firmware/b43legacy-firmware/b43legacy-firmware-3.130.20.0.ebuild b/sys-firmware/b43legacy-firmware/b43legacy-firmware-3.130.20.0.ebuild
new file mode 100644
index 000000000000..6514fcdbef9a
--- /dev/null
+++ b/sys-firmware/b43legacy-firmware/b43legacy-firmware-3.130.20.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+: ${B43_FIRMWARE_SRC_OBJ:=${A}}
+
+MY_P="broadcom-wl-${PV}"
+DESCRIPTION="broadcom firmware for b43legacy/bcm43xx"
+HOMEPAGE="http://linuxwireless.org/en/users/Drivers/b43"
+SRC_URI="http://downloads.openwrt.org/sources/wl_apsta-${PV}.o"
+
+RESTRICT="mirror binchecks strip"
+
+LICENSE="Broadcom"
+SLOT=0
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=">=net-wireless/b43-fwcutter-012"
+
+S=${WORKDIR}
+
+src_unpack() {
+ cp "${DISTDIR}/${A}" "${WORKDIR}" || die
+}
+
+src_compile() {
+ mkdir ebuild-output
+ b43-fwcutter -w ebuild-output $(find -name ${B43_FIRMWARE_SRC_OBJ}) || die
+}
+
+src_install() {
+ insinto /lib/firmware
+ doins -r ebuild-output/*
+}