summaryrefslogtreecommitdiff
path: root/sys-fabric
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
commiteccb70a7f91b2d22582587f26d1a28bb31408b45 (patch)
tree3223e1fd54201bcf4ebecac6fbe87361cbe643e2 /sys-fabric
parenta2810985afabcc31d3eace5e61d8ea25b852ba17 (diff)
gentoo resync : 18.05.2019
Diffstat (limited to 'sys-fabric')
-rw-r--r--sys-fabric/Manifest.gzbin4470 -> 4476 bytes
-rw-r--r--sys-fabric/mstflint/Manifest2
-rw-r--r--sys-fabric/mstflint/mstflint-4.11.0_p5.ebuild35
3 files changed, 37 insertions, 0 deletions
diff --git a/sys-fabric/Manifest.gz b/sys-fabric/Manifest.gz
index 90f3fe28c1f6..116522f72487 100644
--- a/sys-fabric/Manifest.gz
+++ b/sys-fabric/Manifest.gz
Binary files differ
diff --git a/sys-fabric/mstflint/Manifest b/sys-fabric/mstflint/Manifest
index 15d9ba0d7628..83845f8ab7b9 100644
--- a/sys-fabric/mstflint/Manifest
+++ b/sys-fabric/mstflint/Manifest
@@ -1,3 +1,5 @@
DIST mstflint-4.10.0_p3.tar.gz 3208065 BLAKE2B 9d27bc41f3af4af2d430814a892bc26b302f4a57b2287cca4d5a64a37d7dd1b47e3f167b671be9ef1fadaf5dc51dff6094db811951ef1b5c6ad3ce746eb78546 SHA512 72077557f032bfa9c2c0b94f485b58c2d9efa955281997fed605e6351b1cfe73c46d8e4f293f93b58ebc4315d47b3dc3a4e8d72c8938647d34d291a2db89198f
+DIST mstflint-4.11.0_p5.tar.gz 3622665 BLAKE2B 119d1ca04eaf3ebc2e4b8175525fdc87079b27742013f210f8c38d2ac0e83b46c555e4b8b49d7f1562180473c0873456932939e942b1050e9c952a2e3172185a SHA512 c98f24acda519e62fd8db8e170c39c8ffe69b980bc2c9a167f20cfcb2575038648e463de0c7dfad3ddebe098b8a466640b7a125901c033f193a42ef1bfef00d8
EBUILD mstflint-4.10.0_p3.ebuild 975 BLAKE2B 7f1740169c796184319724c9867df215fdf0b5f41478a66c30c56ea99e1807c4f594d08748d3eb24e5907bb6cd14d5b9ded591e9a7b5aa1addd87e93c7304bee SHA512 6cd041b8256b17ff678b8772577ecb43c2992336d22edb3b40ab8cf73e2c6ce8b1bf05238d6c11b17da4349b3b98e8109a0a193b308d5f6049a8b5d552aca35b
+EBUILD mstflint-4.11.0_p5.ebuild 1049 BLAKE2B 2862162a2a80d14253999c6e80ec85a28382c8785516f36e350e39a9f8e079f2bf1c08c8be56567dcf69c4b0e33c353095487d7ab8beddbb85b4c12dc15279da SHA512 570a87bfcbbd8a99e2037acbdd53ee18662ebf332f523ae93ccbcccba38b2595806c43eed802dfaadfc4ba7e15395d4cd40a4269146cd98105bd53aff296a339
MISC metadata.xml 437 BLAKE2B 9e79b5f45579cac7d482a277442a842edac62a78abfb7a53261b74ffb3bd8eae6844121c5afd5fc1a7ec419eb163bc641e95de0f0cbf25deb8850c3010f1abbb SHA512 f8cfef91c9df010f5eaec9406e2440810b1ad8c89f66a869cc36541e615885373dec3cbfaeb9d0087bcaafe410cbe91659162047d67f712c4bb0d7c2046ee97a
diff --git a/sys-fabric/mstflint/mstflint-4.11.0_p5.ebuild b/sys-fabric/mstflint/mstflint-4.11.0_p5.ebuild
new file mode 100644
index 000000000000..5aa3fca67b38
--- /dev/null
+++ b/sys-fabric/mstflint/mstflint-4.11.0_p5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Mstflint - an open source version of MFT (Mellanox Firmware Tools)"
+HOMEPAGE="https://github.com/Mellanox/mstflint"
+LICENSE="|| ( GPL-2 BSD-2 )"
+KEYWORDS="~amd64 ~x86"
+EGIT_COMMIT="840c9c2193fe9145ab177b6e891fd535e1881b43"
+MY_PV=${PV/_p/-}
+MY_P=""
+SRC_URI="${HOMEPAGE}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+IUSE="inband ssl"
+SLOT="0"
+RDEPEND="dev-db/sqlite:3=
+ sys-libs/zlib:=
+ inband? ( sys-fabric/libibmad )
+ ssl? ( dev-libs/openssl:= )"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ default
+ echo '#define TOOLS_GIT_SHA "'${EGIT_COMMIT}'"' > ./common/gitversion.h || die
+}
+
+src_configure() {
+ eautoreconf
+ econf $(use_enable inband) $(use_enable ssl openssl)
+ # /usr/bin/install: cannot create regular file '/var/tmp/portage/.../dev_mgt.py': File exists
+ sed -e 's:^dev_mgt_pylib_DATA = c_dev_mgt.so dev_mgt.py:dev_mgt_pylib_DATA = c_dev_mgt.so:' -i dev_mgt/Makefile || die
+}