summaryrefslogtreecommitdiff
path: root/sys-fabric
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-15 17:37:09 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-15 17:37:09 +0100
commit586819755b4dbfdffdc8a725ab7c0f86095b8489 (patch)
treed6790c838cfe9607c996e4913fdf11bad5fdd528 /sys-fabric
parent3f71901f8c228f4de570abed1831ce3ee425343e (diff)
gentoo resync : 15.09.2018
Diffstat (limited to 'sys-fabric')
-rw-r--r--sys-fabric/Manifest.gzbin4303 -> 4470 bytes
-rw-r--r--sys-fabric/mstflint/Manifest3
-rw-r--r--sys-fabric/mstflint/metadata.xml14
-rw-r--r--sys-fabric/mstflint/mstflint-4.10.0_p3.ebuild33
4 files changed, 50 insertions, 0 deletions
diff --git a/sys-fabric/Manifest.gz b/sys-fabric/Manifest.gz
index 7396e16dd75e..90f3fe28c1f6 100644
--- a/sys-fabric/Manifest.gz
+++ b/sys-fabric/Manifest.gz
Binary files differ
diff --git a/sys-fabric/mstflint/Manifest b/sys-fabric/mstflint/Manifest
new file mode 100644
index 000000000000..15d9ba0d7628
--- /dev/null
+++ b/sys-fabric/mstflint/Manifest
@@ -0,0 +1,3 @@
+DIST mstflint-4.10.0_p3.tar.gz 3208065 BLAKE2B 9d27bc41f3af4af2d430814a892bc26b302f4a57b2287cca4d5a64a37d7dd1b47e3f167b671be9ef1fadaf5dc51dff6094db811951ef1b5c6ad3ce746eb78546 SHA512 72077557f032bfa9c2c0b94f485b58c2d9efa955281997fed605e6351b1cfe73c46d8e4f293f93b58ebc4315d47b3dc3a4e8d72c8938647d34d291a2db89198f
+EBUILD mstflint-4.10.0_p3.ebuild 975 BLAKE2B 7f1740169c796184319724c9867df215fdf0b5f41478a66c30c56ea99e1807c4f594d08748d3eb24e5907bb6cd14d5b9ded591e9a7b5aa1addd87e93c7304bee SHA512 6cd041b8256b17ff678b8772577ecb43c2992336d22edb3b40ab8cf73e2c6ce8b1bf05238d6c11b17da4349b3b98e8109a0a193b308d5f6049a8b5d552aca35b
+MISC metadata.xml 437 BLAKE2B 9e79b5f45579cac7d482a277442a842edac62a78abfb7a53261b74ffb3bd8eae6844121c5afd5fc1a7ec419eb163bc641e95de0f0cbf25deb8850c3010f1abbb SHA512 f8cfef91c9df010f5eaec9406e2440810b1ad8c89f66a869cc36541e615885373dec3cbfaeb9d0087bcaafe410cbe91659162047d67f712c4bb0d7c2046ee97a
diff --git a/sys-fabric/mstflint/metadata.xml b/sys-fabric/mstflint/metadata.xml
new file mode 100644
index 000000000000..3a04694a94c0
--- /dev/null
+++ b/sys-fabric/mstflint/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="github">Mellanox/mstflint</remote-id>
+ </upstream>
+ <use>
+ <flag name="inband">Enable firmware updates for Mellanox SwitchX and ConnectIB devices</flag>
+ </use>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ <name>Zac Medico</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-fabric/mstflint/mstflint-4.10.0_p3.ebuild b/sys-fabric/mstflint/mstflint-4.10.0_p3.ebuild
new file mode 100644
index 000000000000..ed5c82cd271e
--- /dev/null
+++ b/sys-fabric/mstflint/mstflint-4.10.0_p3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Mstflint - an open source version of MFT (Mellanox Firmware Tools)"
+HOMEPAGE="https://github.com/Mellanox/mstflint"
+LICENSE="|| ( GPL-2 BSD-2 )"
+KEYWORDS="~amd64 ~x86"
+EGIT_COMMIT="941bf389b87686ca2be8d6a8fcf0b2ee22955ecc"
+MY_PV=${PV/_p/-}
+MY_P=""
+SRC_URI="${HOMEPAGE}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+IUSE="inband"
+SLOT="0"
+RDEPEND="inband? ( sys-fabric/libibmad )
+ sys-libs/zlib:="
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ default
+ echo '#define TOOLS_GIT_SHA "'${EGIT_COMMIT}'"' > ./common/gitversion.h || die
+}
+
+src_configure() {
+ eautoreconf
+ econf $(use_enable inband)
+ # /usr/bin/install: cannot create regular file '/var/tmp/portage/.../dev_mgt.py': File exists
+ sed -e 's:^dev_mgt_pylib_DATA = c_dev_mgt.so dev_mgt.py:dev_mgt_pylib_DATA = c_dev_mgt.so:' -i dev_mgt/Makefile || die
+}