summaryrefslogtreecommitdiff
path: root/sys-fabric
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
commit129160ec854dca4c3fedb5bcfbcb56930371da0f (patch)
tree53bf797418ac5e9b99c41ca0382c87b82421e5de /sys-fabric
parent441d1370330332b7d78f238d2f5e13f7aed5e4e0 (diff)
gentoo new year resync : 01.01.2021
Diffstat (limited to 'sys-fabric')
-rw-r--r--sys-fabric/Manifest.gzbin4318 -> 4322 bytes
-rw-r--r--sys-fabric/libcxgb3/Manifest3
-rw-r--r--sys-fabric/libcxgb3/files/libcxgb3-1.3.1-fno-common.patch41
-rw-r--r--sys-fabric/libcxgb3/libcxgb3-1.3.1-r2.ebuild5
4 files changed, 46 insertions, 3 deletions
diff --git a/sys-fabric/Manifest.gz b/sys-fabric/Manifest.gz
index b26732ad8e91..dad7a57ece47 100644
--- a/sys-fabric/Manifest.gz
+++ b/sys-fabric/Manifest.gz
Binary files differ
diff --git a/sys-fabric/libcxgb3/Manifest b/sys-fabric/libcxgb3/Manifest
index 33c8fb7a4f6d..ccc1e1efda19 100644
--- a/sys-fabric/libcxgb3/Manifest
+++ b/sys-fabric/libcxgb3/Manifest
@@ -1,3 +1,4 @@
+AUX libcxgb3-1.3.1-fno-common.patch 1029 BLAKE2B d1aa234ee4bca9e705f420a2db003c5077c52cff6f24f37f235ffb5d00af9b156b66cf507be1712c7d447ded580427c07f5d6069e444011e2b835666cc965f55 SHA512 e136a40a76f0e3c4020f0ad052443204a501655586d253c5a0a0d5d8ce4ae19e7b99614e7599859c05bbb5ed615a386adebe6ef2939f3f1722c1b88578adabb9
DIST OFED-3.12-rc1.tgz 22055476 BLAKE2B 49e6411721392f418369a292513709f396fbb0f17001687aa15b5c0acdc91013cc67354e5978df56452178af7fbbd338a7ff408592ff9126a3045b9bb27375fe SHA512 9f834d6982ab7e8ab47a8b5c958ab2e4c238ef983e47798e7f06655f69672ea1e996297939b381f26ed8c39552f6e62156173d5ddd2f0a7b6cad6aecdd973944
-EBUILD libcxgb3-1.3.1-r2.ebuild 517 BLAKE2B 55fdd49ef921d97f310dd9be7e4062c2a2072a003ffe0d23692dfec3dc11f2ee39a339ddaad81e8058f71ef1b6fa4cf0b43a3963a707cc36f4b2a1184dc19a01 SHA512 75bbbdd70079872503245f9f69476bfc980029767e3eff747b7c363ee55fd73116afbec86677deafd7acebbd1c02bdd2ac0dff65cbd672b08c0159d7412b016d
+EBUILD libcxgb3-1.3.1-r2.ebuild 556 BLAKE2B daead3805d55549ef29c8900508b76698c2244cf548c9a278e23e421c1e23c5e14840d60a158c972f71c050cf533ecefa57c66abe34875039babddcf4f07fe31 SHA512 286b56db78ed40b7201113abcbede6c52e6295ba8d8f2f61772911023e2cd4246d13c65744cfedde5e98853e7f334b1eec10ffd5bc6cd382edf970535cb2cb1c
MISC metadata.xml 253 BLAKE2B 2fbd23e1eeca2d6a1474e03aeaa1ad81f16f00141d906ca087f01b67a69e065cac2b3600c2da212ca9fdaf4765788a58ec12b6cd6a45323e5b524dbdb1ce0a77 SHA512 0894860713279dc39bbe7ce3491002710b62c4476198984a0deb6328cb0012c19d7a5546299960bbe600ee240e62a603dd4c4fa04325a753cc0b7c4044c30aba
diff --git a/sys-fabric/libcxgb3/files/libcxgb3-1.3.1-fno-common.patch b/sys-fabric/libcxgb3/files/libcxgb3-1.3.1-fno-common.patch
new file mode 100644
index 000000000000..e23ffa8682c2
--- /dev/null
+++ b/sys-fabric/libcxgb3/files/libcxgb3-1.3.1-fno-common.patch
@@ -0,0 +1,41 @@
+--- a/src/cxio_wr.h
++++ b/src/cxio_wr.h
+@@ -638,9 +638,9 @@ static inline unsigned t3_cq_depth(struct t3_cq *cq)
+ return (1UL<<cq->size_log2);
+ }
+
+-unsigned long iwch_page_size;
+-unsigned long iwch_page_shift;
+-unsigned long iwch_page_mask;
++extern unsigned long iwch_page_size;
++extern unsigned long iwch_page_shift;
++extern unsigned long iwch_page_mask;
+
+ #define PAGE_ALIGN(x) (((x) + iwch_page_mask) & ~iwch_page_mask)
+
+--- a/src/iwch.c
++++ b/src/iwch.c
+@@ -63,6 +63,10 @@
+ .device = PCI_DEVICE_ID_CHELSIO_##d, \
+ .type = CHELSIO_##t }
+
++extern unsigned long iwch_page_size;
++extern unsigned long iwch_page_mask;
++extern unsigned long iwch_page_shift;
++
+ struct {
+ unsigned vendor;
+ unsigned device;
+--- a/src/verbs.c
++++ b/src/verbs.c
+@@ -45,6 +45,10 @@
+ #include "iwch.h"
+ #include "iwch-abi.h"
+
++unsigned long iwch_page_size;
++unsigned long iwch_page_shift;
++unsigned long iwch_page_mask;
++
+ int iwch_query_device(struct ibv_context *context, struct ibv_device_attr *attr)
+ {
+ struct ibv_query_device cmd;
diff --git a/sys-fabric/libcxgb3/libcxgb3-1.3.1-r2.ebuild b/sys-fabric/libcxgb3/libcxgb3-1.3.1-r2.ebuild
index 2d5bc5c6608d..20ffdc32534e 100644
--- a/sys-fabric/libcxgb3/libcxgb3-1.3.1-r2.ebuild
+++ b/sys-fabric/libcxgb3/libcxgb3-1.3.1-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=6
OFED_VER="3.12"
OFED_RC="1"
@@ -12,12 +12,13 @@ inherit openib
DESCRIPTION="OpenIB - driver for Chelsio T3-based iWARP (RDMA over IP/ethernet)"
KEYWORDS="amd64 ~x86 ~amd64-linux"
-IUSE=""
DEPEND="sys-fabric/libibverbs:${SLOT}"
RDEPEND="${DEPEND}"
block_other_ofed_versions
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
+
src_configure() {
econf --disable-static
}