summaryrefslogtreecommitdiff
path: root/sys-devel/ucpp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
commitfab849d1daed0ba7f2ac497d07985c3dbb692543 (patch)
tree10baa743a5340b42ad538dd19d48669ccac209b1 /sys-devel/ucpp
parent73c318acdaf6f8309d68bd266051e6dd1f1bd787 (diff)
gentoo resync : 16.06.2019
Diffstat (limited to 'sys-devel/ucpp')
-rw-r--r--sys-devel/ucpp/Manifest3
-rw-r--r--sys-devel/ucpp/ucpp-1.3.4.ebuild9
-rw-r--r--sys-devel/ucpp/ucpp-9999.ebuild31
3 files changed, 5 insertions, 38 deletions
diff --git a/sys-devel/ucpp/Manifest b/sys-devel/ucpp/Manifest
index 033c33b9e5ae..ea6fa5122cd4 100644
--- a/sys-devel/ucpp/Manifest
+++ b/sys-devel/ucpp/Manifest
@@ -1,4 +1,3 @@
DIST ucpp-1.3.4.tar.xz 274488 BLAKE2B be43b8c88de2cd32514ecf7dc429c0ca5e88150594c9868fd6d8c3d90a0aabfc6e0f0741d75e4f558de426df7d6c54a3bc7e8e362c5066672f5fe9096cbedc18 SHA512 f9ea88e8f53e728a5b0fcb9084d6d6e140737b00fe350a9c6bc53ef2bb5f7b09d3c9d9a4a2147f635d796247e1b920fd3fea0cdce3ec3f4578694162c2f4c2a6
-EBUILD ucpp-1.3.4.ebuild 564 BLAKE2B 881fc7ebed00de270cec04ee837ecef2959425937c3c6a835a5b75862d1f6a9f2e0bf5f48c7252ef6706eda263a8444074268ea428bc761d9331953b188c8d5a SHA512 92f798d38a416f391e5b977a59b2e3ee75767de9526147ca2c660ed03e54dbb7590dfcf886a0410c749a63c2cc383f80592345657731e4660508b3154ae06f53
-EBUILD ucpp-9999.ebuild 560 BLAKE2B 8ec4d2da50bcea1923814562e9be1357810d23cbf503bb1dc1bf8146d228c2ab47cb18bb4cff449678b2cb5542269a3499a3de0b4914fe4364c4a45748db23b4 SHA512 0e81ee83c29a4ddb4ae9b22222a683192afcb8c494f30d90b8af3cd0077a8a6b95322208d4014e6679d84063c075e6102bbeb27386aa098593574dbf863dfe76
+EBUILD ucpp-1.3.4.ebuild 589 BLAKE2B 88f336b28a41317c43e53bea4a7d15525f9b2513d9e4a9010cc669b87ad06b791576cb3c0a7465f1cba27b893d16691770658573170d359082855913445ca866 SHA512 371e52d0d9797126d66169b535dc6719be33bf480ea6d68f2cb44ae09f1c23b4d4e3ad38209c01695b4ce3dbf3098f685ccb796a1bd88b27497389437ccee8cc
MISC metadata.xml 368 BLAKE2B 06732720ef930d1a5d0f621bf003db64ec8637590d5b25e5ce1dbc701377d72bda00600f889294f864a15534b22f14ba70138e410038217d57bbaa36af3de2af SHA512 4eb1fce17c77d2e4123e763b76f102cf95e4e2108606949aa9ce87a55dc76fb3159f98fcfc8ec50b98c91bac7fc9e49430a4497b8b8b0edd8e9d5ca0804c1a2b
diff --git a/sys-devel/ucpp/ucpp-1.3.4.ebuild b/sys-devel/ucpp/ucpp-1.3.4.ebuild
index a665fce81592..54bf56e743f2 100644
--- a/sys-devel/ucpp/ucpp-1.3.4.ebuild
+++ b/sys-devel/ucpp/ucpp-1.3.4.ebuild
@@ -1,9 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-inherit eutils
+EAPI=7
DESCRIPTION="A quick and light preprocessor, but anyway fully compliant to C99"
HOMEPAGE="https://code.google.com/p/ucpp/"
@@ -23,5 +21,6 @@ src_configure() {
src_install() {
default
- prune_libtool_files --all
+ # package provides .pc files
+ find "${D}" -name '*.la' -delete || die
}
diff --git a/sys-devel/ucpp/ucpp-9999.ebuild b/sys-devel/ucpp/ucpp-9999.ebuild
deleted file mode 100644
index 81b7839a7a4d..000000000000
--- a/sys-devel/ucpp/ucpp-9999.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-EGIT_REPO_URI="https://github.com/scarabeusiv/ucpp.git"
-inherit eutils git-2 autotools
-
-DESCRIPTION="A quick and light preprocessor, but anyway fully compliant to C99"
-HOMEPAGE="https://github.com/scarabeusiv/ucpp"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS=""
-IUSE="static-libs"
-
-src_prepare() {
- eautoreconf
-}
-
-src_configure() {
- econf \
- --disable-werror \
- $(use_enable static-libs static)
-}
-
-src_install() {
- default
-
- prune_libtool_files --all
-}