summaryrefslogtreecommitdiff
path: root/sys-devel/smatch/smatch-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /sys-devel/smatch/smatch-9999.ebuild
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'sys-devel/smatch/smatch-9999.ebuild')
-rw-r--r--sys-devel/smatch/smatch-9999.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/sys-devel/smatch/smatch-9999.ebuild b/sys-devel/smatch/smatch-9999.ebuild
index 4e3cca48e997..8ba49a55ed46 100644
--- a/sys-devel/smatch/smatch-9999.ebuild
+++ b/sys-devel/smatch/smatch-9999.ebuild
@@ -23,12 +23,14 @@ IUSE=""
RDEPEND="dev-db/sqlite"
DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
src_prepare() {
default
sed -i \
-e '/^CFLAGS =/{s:=:+=:;s:-O2 -finline-functions:${CPPFLAGS}:}' \
+ -e 's:pkg-config:$(PKG_CONFIG):' \
Makefile || die
}
@@ -40,6 +42,7 @@ _emake() {
AR="$(tc-getAR)" \
CC="$(tc-getCC)" \
LD='$(CC)' \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)" \
HAVE_GTK2=no \
HAVE_LLVM=no \
HAVE_LIBXML=no \