summaryrefslogtreecommitdiff
path: root/sys-devel/slibtool/slibtool-0.5.33.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /sys-devel/slibtool/slibtool-0.5.33.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'sys-devel/slibtool/slibtool-0.5.33.ebuild')
-rw-r--r--sys-devel/slibtool/slibtool-0.5.33.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-devel/slibtool/slibtool-0.5.33.ebuild b/sys-devel/slibtool/slibtool-0.5.33.ebuild
new file mode 100644
index 000000000000..6fe991b4272d
--- /dev/null
+++ b/sys-devel/slibtool/slibtool-0.5.33.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+# git.foss21.org is the official repository per upstream
+DESCRIPTION="A skinny libtool implementation, written in C"
+HOMEPAGE="https://git.foss21.org/slibtool"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.foss21.org/slibtool"
+else
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/midipix.asc
+ inherit verify-sig
+
+ SRC_URI="https://dl.midipix.org/slibtool/${P}.tar.xz"
+ SRC_URI+=" verify-sig? ( https://dl.midipix.org/slibtool/${P}.tar.xz.sig )"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+
+ BDEPEND="verify-sig? ( app-crypt/openpgp-keys-midipix )"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+src_configure() {
+ # Custom configure script (not generated by autoconf)
+ ./configure \
+ --compiler=$(tc-getCC) \
+ --host=${CHOST} \
+ --prefix="${EPREFIX}"/usr \
+ || die
+}