summaryrefslogtreecommitdiff
path: root/sys-devel/reflex/reflex-20230521.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-23 08:58:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-23 08:58:35 +0100
commit955b5fcaf4acc77c39a1f145d7c56e99f13083a7 (patch)
tree1141703ebc6ca24ff935b991e261d716a5d98243 /sys-devel/reflex/reflex-20230521.ebuild
parent24c53d42e0294f4f6e36fbb051891af86c9ae503 (diff)
gentoo auto-resync : 23:05:2023 - 08:58:35
Diffstat (limited to 'sys-devel/reflex/reflex-20230521.ebuild')
-rw-r--r--sys-devel/reflex/reflex-20230521.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/sys-devel/reflex/reflex-20230521.ebuild b/sys-devel/reflex/reflex-20230521.ebuild
new file mode 100644
index 000000000000..40734b6c5168
--- /dev/null
+++ b/sys-devel/reflex/reflex-20230521.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/thomasdickey.asc
+inherit verify-sig
+
+DESCRIPTION="This is a variant of the flex fast lexical scanner"
+HOMEPAGE="https://invisible-island.net/reflex/"
+SRC_URI="https://invisible-island.net/archives/${PN}/${P}.tgz"
+SRC_URI+=" verify-sig? ( https://invisible-island.net/archives/${PN}/${P}.tgz.asc )"
+
+LICENSE="FLEX"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="verify-sig? ( sec-keys/openpgp-keys-thomasdickey )"
+
+src_configure() {
+ econf --with-manpage-format=formatted
+}