summaryrefslogtreecommitdiff
path: root/sys-devel/qconf/qconf-2.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /sys-devel/qconf/qconf-2.5.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'sys-devel/qconf/qconf-2.5.ebuild')
-rw-r--r--sys-devel/qconf/qconf-2.5.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-devel/qconf/qconf-2.5.ebuild b/sys-devel/qconf/qconf-2.5.ebuild
new file mode 100644
index 000000000000..0064bce46584
--- /dev/null
+++ b/sys-devel/qconf/qconf-2.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils
+
+DESCRIPTION="./configure like generator for qmake-based projects"
+HOMEPAGE="https://github.com/psi-im/qconf"
+SRC_URI="https://github.com/psi-im/qconf/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtxml:5
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # not autotools configure, so don't use econf
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --qtdir="$(qt5_get_libdir)/qt5" \
+ --extraconf=QMAKE_STRIP= \
+ --verbose || die "configure failed"
+
+ # just to set all the Gentoo toolchain flags
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+ dodoc -r examples
+}