summaryrefslogtreecommitdiff
path: root/sys-devel/make/make-4.2.93.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-20 19:28:42 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-20 19:28:42 +0000
commit032a3dbb5d4ea63ec6c2ceb39c067ea6424b5792 (patch)
treed46be9dbc767750a192f7a4d505757f2eec582f3 /sys-devel/make/make-4.2.93.ebuild
parent6ec19c7f1bc4aa70e5f8a86cd29d579a95d97035 (diff)
gentoo resync : 20.01.2020
Diffstat (limited to 'sys-devel/make/make-4.2.93.ebuild')
-rw-r--r--sys-devel/make/make-4.2.93.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/sys-devel/make/make-4.2.93.ebuild b/sys-devel/make/make-4.2.93.ebuild
deleted file mode 100644
index e15a331d2423..000000000000
--- a/sys-devel/make/make-4.2.93.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic
-
-DESCRIPTION="Standard tool to compile source trees"
-HOMEPAGE="https://www.gnu.org/software/make/make.html"
-if [[ "$(ver_cut 3)" -ge 90 ]] ; then
- SRC_URI="mirror://gnu-alpha//make/${P}.tar.gz"
-else
- SRC_URI="mirror://gnu//make/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-LICENSE="GPL-3+"
-SLOT="0"
-IUSE="guile nls static"
-
-DEPEND="guile? ( >=dev-scheme/guile-1.8:= )"
-BDEPEND="nls? ( sys-devel/gettext )"
-RDEPEND="${DEPEND}
- nls? ( virtual/libintl )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.82-darwin-library_search-dylib.patch
- "${FILESDIR}"/${PN}-4.2-default-cxx.patch
-)
-
-src_prepare() {
- # sources were moved into src directory
- cd src || die
- default
-}
-
-src_configure() {
- use static && append-ldflags -static
- local myeconfargs=(
- --program-prefix=g
- $(use_with guile)
- $(use_enable nls)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS NEWS README*
- if [[ ${USERLAND} == "GNU" ]] ; then
- # we install everywhere as 'gmake' but on GNU systems,
- # symlink 'make' to 'gmake'
- dosym gmake /usr/bin/make
- dosym gmake.1 /usr/share/man/man1/make.1
- fi
-}