summaryrefslogtreecommitdiff
path: root/sys-devel/llvmgold/llvmgold-5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-devel/llvmgold/llvmgold-5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-devel/llvmgold/llvmgold-5.ebuild')
-rw-r--r--sys-devel/llvmgold/llvmgold-5.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-devel/llvmgold/llvmgold-5.ebuild b/sys-devel/llvmgold/llvmgold-5.ebuild
new file mode 100644
index 000000000000..b65d437828be
--- /dev/null
+++ b/sys-devel/llvmgold/llvmgold-5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="LLVMgold plugin symlink for autoloading"
+HOMEPAGE="https://llvm.org/"
+SRC_URI=""
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="sys-devel/llvm:${PV}[gold]
+ !sys-devel/llvm:0"
+
+S=${WORKDIR}
+
+src_install() {
+ dodir "/usr/${CHOST}/binutils-bin/lib/bfd-plugins"
+ dosym "../../../../lib/llvm/${PV}/$(get_libdir)/LLVMgold.so" \
+ "/usr/${CHOST}/binutils-bin/lib/bfd-plugins/LLVMgold.so"
+}