summaryrefslogtreecommitdiff
path: root/sys-devel/llvmgold/llvmgold-5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
commit36ac65103bf5503e5bad1ecc7e8cb9e7643f6840 (patch)
treed9d1fbc20509d4c90f57fb2d9e1459bc8034c831 /sys-devel/llvmgold/llvmgold-5.ebuild
parenta1392efe64137262023d92492396ca9156d22396 (diff)
Revert "gentoo resync : 13.09.2019"
This reverts commit a1392efe64137262023d92492396ca9156d22396.
Diffstat (limited to 'sys-devel/llvmgold/llvmgold-5.ebuild')
-rw-r--r--sys-devel/llvmgold/llvmgold-5.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-devel/llvmgold/llvmgold-5.ebuild b/sys-devel/llvmgold/llvmgold-5.ebuild
new file mode 100644
index 000000000000..a3af49b27d74
--- /dev/null
+++ b/sys-devel/llvmgold/llvmgold-5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="LLVMgold plugin symlink for autoloading"
+HOMEPAGE="https://llvm.org/"
+SRC_URI=""
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 arm ~arm64 x86 ~amd64-linux"
+IUSE=""
+
+RDEPEND="sys-devel/llvm:${PV}[gold]
+ !sys-devel/llvm:0"
+
+S=${WORKDIR}
+
+src_install() {
+ dodir "/usr/${CHOST}/binutils-bin/lib/bfd-plugins"
+ dosym "../../../../lib/llvm/${PV}/$(get_libdir)/LLVMgold.so" \
+ "/usr/${CHOST}/binutils-bin/lib/bfd-plugins/LLVMgold.so"
+}