summaryrefslogtreecommitdiff
path: root/sys-devel/llvm/llvm-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-24 10:19:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-24 10:19:03 +0000
commitb279bbe94522565b8feb19b8e5f377d3ea76f157 (patch)
treee4790abc54cd850232f7d7de49e371fdfe8976c7 /sys-devel/llvm/llvm-9999.ebuild
parentc5283d322accc6097afec74eab24550829788bab (diff)
gentoo resync : 24.03.2018
Diffstat (limited to 'sys-devel/llvm/llvm-9999.ebuild')
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 7699f3364d0c..414c82e01aa5 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -174,7 +174,10 @@ multilib_src_configure() {
# workaround BMI bug in gcc-7 (fixed in 7.4)
# https://bugs.gentoo.org/649880
- if tc-is-gcc && [[ $(gcc-major-version) -eq 7 && $(gcc-minor-version) -lt 4 ]]; then
+ # apply only to x86, https://bugs.gentoo.org/650506
+ if tc-is-gcc && [[ ${MULTILIB_ABI_FLAG} == abi_x86* ]] &&
+ [[ $(gcc-major-version) -eq 7 && $(gcc-minor-version) -lt 4 ]]
+ then
local CFLAGS="${CFLAGS} -mno-bmi"
local CXXFLAGS="${CXXFLAGS} -mno-bmi"
fi