summaryrefslogtreecommitdiff
path: root/sys-devel/llvm/llvm-19.0.0_pre20240322.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-27 13:01:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-27 13:01:55 +0000
commitf9dd41d94a755be4b93be4655558eb79bb87113b (patch)
tree2794ea86a1752fe099308731fedd7bd527c3bd0f /sys-devel/llvm/llvm-19.0.0_pre20240322.ebuild
parente5558bb40ba46b03d0c8e82ae60dce9a32933989 (diff)
gentoo auto-resync : 27:03:2024 - 13:01:55
Diffstat (limited to 'sys-devel/llvm/llvm-19.0.0_pre20240322.ebuild')
-rw-r--r--sys-devel/llvm/llvm-19.0.0_pre20240322.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/sys-devel/llvm/llvm-19.0.0_pre20240322.ebuild b/sys-devel/llvm/llvm-19.0.0_pre20240322.ebuild
index b4633658a186..8624219a7e20 100644
--- a/sys-devel/llvm/llvm-19.0.0_pre20240322.ebuild
+++ b/sys-devel/llvm/llvm-19.0.0_pre20240322.ebuild
@@ -345,6 +345,11 @@ get_distribution_components() {
}
multilib_src_configure() {
+ if use ppc && tc-is-gcc && [[ $(gcc-major-version) -lt 14 ]]; then
+ # Workaround for bug #880677
+ append-flags $(test-flags-CXX -fno-ipa-sra -fno-ipa-modref -fno-ipa-icf)
+ fi
+
# ODR violations (bug #917536, bug #926529). Just do it for GCC for now
# to avoid people grumbling. GCC is, anecdotally, more likely to miscompile
# LLVM with LTO anyway (which is not necessarily its fault).