summaryrefslogtreecommitdiff
path: root/sys-devel/llvm/llvm-18.0.0.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-25 20:44:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-25 20:44:11 +0100
commit159ec3f090554ee5d7f61b2da553833fb7566f99 (patch)
tree8be8aa1641e20a8dfa1bab1b818367b702817c8a /sys-devel/llvm/llvm-18.0.0.9999.ebuild
parent2000f81da4dc9971f6e1e5d00b315816d4188f4c (diff)
gentoo auto-resync : 25:10:2023 - 20:44:11
Diffstat (limited to 'sys-devel/llvm/llvm-18.0.0.9999.ebuild')
-rw-r--r--sys-devel/llvm/llvm-18.0.0.9999.ebuild5
1 files changed, 1 insertions, 4 deletions
diff --git a/sys-devel/llvm/llvm-18.0.0.9999.ebuild b/sys-devel/llvm/llvm-18.0.0.9999.ebuild
index ae46685bcec9..0fe2c5be8d56 100644
--- a/sys-devel/llvm/llvm-18.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-18.0.0.9999.ebuild
@@ -21,7 +21,7 @@ LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA BSD public-domain rc"
SLOT="${LLVM_MAJOR}/${LLVM_SOABI}"
IUSE="
+binutils-plugin +debug debuginfod doc exegesis libedit +libffi
- ncurses test xar xml z3 zstd
+ ncurses test xml z3 zstd
"
RESTRICT="!test? ( test )"
@@ -35,7 +35,6 @@ RDEPEND="
libedit? ( dev-libs/libedit:0=[${MULTILIB_USEDEP}] )
libffi? ( >=dev-libs/libffi-3.0.13-r1:0=[${MULTILIB_USEDEP}] )
ncurses? ( >=sys-libs/ncurses-5.9-r3:0=[${MULTILIB_USEDEP}] )
- xar? ( app-arch/xar )
xml? ( dev-libs/libxml2:2=[${MULTILIB_USEDEP}] )
z3? ( >=sci-mathematics/z3-4.7.1:0=[${MULTILIB_USEDEP}] )
zstd? ( app-arch/zstd:=[${MULTILIB_USEDEP}] )
@@ -382,8 +381,6 @@ multilib_src_configure() {
-DFFI_INCLUDE_DIR="${ffi_cflags#-I}"
-DFFI_LIBRARY_DIR="${ffi_ldflags#-L}"
- # used only for llvm-objdump tool
- -DLLVM_HAVE_LIBXAR=$(multilib_native_usex xar 1 0)
-DPython3_EXECUTABLE="${PYTHON}"