summaryrefslogtreecommitdiff
path: root/sys-devel/llvm/llvm-11.0.0.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /sys-devel/llvm/llvm-11.0.0.9999.ebuild
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'sys-devel/llvm/llvm-11.0.0.9999.ebuild')
-rw-r--r--sys-devel/llvm/llvm-11.0.0.9999.ebuild56
1 files changed, 33 insertions, 23 deletions
diff --git a/sys-devel/llvm/llvm-11.0.0.9999.ebuild b/sys-devel/llvm/llvm-11.0.0.9999.ebuild
index f6ed4b7a9be5..5af65c0f4a0d 100644
--- a/sys-devel/llvm/llvm-11.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-11.0.0.9999.ebuild
@@ -3,9 +3,9 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
-inherit cmake-utils llvm.org multilib-minimal multiprocessing \
- pax-utils python-any-r1 toolchain-funcs
+PYTHON_COMPAT=( python3_{6..9} )
+inherit cmake llvm.org multilib-minimal multiprocessing pax-utils \
+ python-any-r1 toolchain-funcs
DESCRIPTION="Low Level Virtual Machine"
HOMEPAGE="https://llvm.org/"
@@ -58,12 +58,11 @@ BDEPEND="
<sys-libs/libcxx-$(ver_cut 1-3).9999
>=sys-devel/binutils-apple-5.1
)
- doc? ( $(python_gen_any_dep '
- dev-python/recommonmark[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- ') )
libffi? ( virtual/pkgconfig )
- ${PYTHON_DEPS}"
+ $(python_gen_any_dep '
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ doc? ( dev-python/recommonmark[${PYTHON_USEDEP}] )
+ ')"
# There are no file collisions between these versions but having :0
# installed means llvm-config there will take precedence.
RDEPEND="${RDEPEND}
@@ -75,9 +74,10 @@ PDEPEND="sys-devel/llvm-common
CMAKE_BUILD_TYPE=RelWithDebInfo
python_check_deps() {
- use doc || return 0
-
- has_version -b "dev-python/recommonmark[${PYTHON_USEDEP}]" &&
+ if use doc; then
+ has_version -b "dev-python/recommonmark[${PYTHON_USEDEP}]" ||
+ return 1
+ fi
has_version -b "dev-python/sphinx[${PYTHON_USEDEP}]"
}
@@ -138,6 +138,10 @@ check_distribution_components() {
distribution|llvm-libraries)
continue
;;
+ # used only w/ USE=doc
+ docs-llvm-html)
+ continue
+ ;;
esac
all_targets+=( "${l}" )
@@ -180,11 +184,18 @@ src_prepare() {
# Update config.guess to support more systems
cp "${BROOT}/usr/share/gnuconfig/config.guess" cmake/ || die
- # User patches + QA
- cmake-utils_src_prepare
+ # manpages don't use markdown
+ if ! use doc; then
+ sed -i -e '/source_parsers/d' docs/conf.py || die
+ fi
# Verify that the live ebuild is up-to-date
check_live_ebuild
+
+ # cmake eclasses suck by forcing ${S} here
+ CMAKE_USE_DIR=${S} \
+ S=${WORKDIR} \
+ cmake_src_prepare
}
# Is LLVM being linked against libc++?
@@ -301,12 +312,13 @@ get_distribution_components() {
# python modules
opt-viewer
- )
- use doc && out+=(
+ # manpages
docs-dsymutil-man
docs-llvm-dwarfdump-man
docs-llvm-man
+ )
+ use doc && out+=(
docs-llvm-html
)
@@ -388,13 +400,11 @@ multilib_src_configure() {
if multilib_is_native_abi; then
mycmakeargs+=(
- -DLLVM_BUILD_DOCS=$(usex doc)
+ -DLLVM_BUILD_DOCS=ON
-DLLVM_ENABLE_OCAMLDOC=OFF
- -DLLVM_ENABLE_SPHINX=$(usex doc)
+ -DLLVM_ENABLE_SPHINX=ON
-DLLVM_ENABLE_DOXYGEN=OFF
-DLLVM_INSTALL_UTILS=ON
- )
- use doc && mycmakeargs+=(
-DCMAKE_INSTALL_MANDIR="${EPREFIX}/usr/lib/llvm/${SLOT}/share/man"
-DLLVM_INSTALL_SPHINX_HTML_DIR="${EPREFIX}/usr/share/doc/${PF}/html"
-DSPHINX_WARNINGS_AS_ERRORS=OFF
@@ -426,13 +436,13 @@ multilib_src_configure() {
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
- cmake-utils_src_configure
+ cmake_src_configure
multilib_is_native_abi && check_distribution_components
}
multilib_src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
pax-mark m "${BUILD_DIR}"/bin/llvm-rtdyld
pax-mark m "${BUILD_DIR}"/bin/lli
@@ -448,7 +458,7 @@ multilib_src_compile() {
multilib_src_test() {
# respect TMPDIR!
local -x LIT_PRESERVES_TMP=1
- cmake-utils_src_make check
+ cmake_build check
}
src_install() {
@@ -468,7 +478,7 @@ src_install() {
}
multilib_src_install() {
- DESTDIR=${D} cmake-utils_src_make install-distribution
+ DESTDIR=${D} cmake_build install-distribution
# move headers to /usr/include for wrapping
rm -rf "${ED}"/usr/include || die