summaryrefslogtreecommitdiff
path: root/sys-devel/llvm/llvm-11.0.0.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /sys-devel/llvm/llvm-11.0.0.9999.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'sys-devel/llvm/llvm-11.0.0.9999.ebuild')
-rw-r--r--sys-devel/llvm/llvm-11.0.0.9999.ebuild54
1 files changed, 35 insertions, 19 deletions
diff --git a/sys-devel/llvm/llvm-11.0.0.9999.ebuild b/sys-devel/llvm/llvm-11.0.0.9999.ebuild
index 6ee898821d6b..8e4357a1098c 100644
--- a/sys-devel/llvm/llvm-11.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-11.0.0.9999.ebuild
@@ -10,6 +10,7 @@ inherit cmake llvm.org multilib-minimal pax-utils python-any-r1 \
DESCRIPTION="Low Level Virtual Machine"
HOMEPAGE="https://llvm.org/"
LLVM_COMPONENTS=( llvm )
+LLVM_MANPAGES=build
llvm.org_set_globals
# Those are in lib/Targets, without explicit CMakeLists.txt mention
@@ -53,16 +54,18 @@ DEPEND="${RDEPEND}
gold? ( sys-libs/binutils-libs )"
BDEPEND="
dev-lang/perl
+ >=dev-util/cmake-3.16
sys-devel/gnuconfig
kernel_Darwin? (
<sys-libs/libcxx-$(ver_cut 1-3).9999
>=sys-devel/binutils-apple-5.1
)
- libffi? ( virtual/pkgconfig )
- $(python_gen_any_dep '
+ doc? ( $(python_gen_any_dep '
+ dev-python/recommonmark[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
- doc? ( dev-python/recommonmark[${PYTHON_USEDEP}] )
- ')"
+ ') )
+ libffi? ( virtual/pkgconfig )
+ ${PYTHON_DEPS}"
# There are no file collisions between these versions but having :0
# installed means llvm-config there will take precedence.
RDEPEND="${RDEPEND}
@@ -71,10 +74,9 @@ PDEPEND="sys-devel/llvm-common
gold? ( >=sys-devel/llvmgold-${SLOT} )"
python_check_deps() {
- if use doc; then
- has_version -b "dev-python/recommonmark[${PYTHON_USEDEP}]" ||
- return 1
- fi
+ use doc || return 0
+
+ has_version -b "dev-python/recommonmark[${PYTHON_USEDEP}]" &&
has_version -b "dev-python/sphinx[${PYTHON_USEDEP}]"
}
@@ -137,7 +139,7 @@ check_distribution_components() {
;;
# used only w/ USE=doc
docs-llvm-html)
- continue
+ use doc || continue
;;
esac
@@ -301,12 +303,16 @@ get_distribution_components() {
# python modules
opt-viewer
-
- # manpages
- docs-dsymutil-man
- docs-llvm-dwarfdump-man
- docs-llvm-man
)
+
+ if llvm_are_manpages_built; then
+ out+=(
+ # manpages
+ docs-dsymutil-man
+ docs-llvm-dwarfdump-man
+ docs-llvm-man
+ )
+ fi
use doc && out+=(
docs-llvm-html
)
@@ -362,6 +368,8 @@ multilib_src_configure() {
# used only for llvm-objdump tool
-DHAVE_LIBXAR=$(multilib_native_usex xar 1 0)
+ -DPython3_EXECUTABLE="${PYTHON}"
+
# disable OCaml bindings (now in dev-ml/llvm-ocaml)
-DOCAMLFIND=NO
)
@@ -388,15 +396,22 @@ multilib_src_configure() {
)
if multilib_is_native_abi; then
+ local build_docs=OFF
+ if llvm_are_manpages_built; then
+ build_docs=ON
+ mycmakeargs+=(
+ -DCMAKE_INSTALL_MANDIR="${EPREFIX}/usr/lib/llvm/${SLOT}/share/man"
+ -DLLVM_INSTALL_SPHINX_HTML_DIR="${EPREFIX}/usr/share/doc/${PF}/html"
+ -DSPHINX_WARNINGS_AS_ERRORS=OFF
+ )
+ fi
+
mycmakeargs+=(
- -DLLVM_BUILD_DOCS=ON
+ -DLLVM_BUILD_DOCS=${build_docs}
-DLLVM_ENABLE_OCAMLDOC=OFF
- -DLLVM_ENABLE_SPHINX=ON
+ -DLLVM_ENABLE_SPHINX=${build_docs}
-DLLVM_ENABLE_DOXYGEN=OFF
-DLLVM_INSTALL_UTILS=ON
- -DCMAKE_INSTALL_MANDIR="${EPREFIX}/usr/lib/llvm/${SLOT}/share/man"
- -DLLVM_INSTALL_SPHINX_HTML_DIR="${EPREFIX}/usr/share/doc/${PF}/html"
- -DSPHINX_WARNINGS_AS_ERRORS=OFF
)
use gold && mycmakeargs+=(
-DLLVM_BINUTILS_INCDIR="${EPREFIX}"/usr/include
@@ -491,6 +506,7 @@ multilib_src_install_all() {
_EOF_
docompress "/usr/lib/llvm/${SLOT}/share/man"
+ llvm_install_manpages
}
pkg_postinst() {