summaryrefslogtreecommitdiff
path: root/sys-devel/llvm-common
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-18 18:58:09 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-18 18:58:09 +0000
commit6ec19c7f1bc4aa70e5f8a86cd29d579a95d97035 (patch)
tree860348d8573f52d9ddf8a87c31099b8bb3a04806 /sys-devel/llvm-common
parent1118729405d206538433388e0a8bd578f7ae7303 (diff)
gentoo resync : 18.01.2020
Diffstat (limited to 'sys-devel/llvm-common')
-rw-r--r--sys-devel/llvm-common/llvm-common-11.0.0.9999.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-11.0.0.9999.ebuild b/sys-devel/llvm-common/llvm-common-11.0.0.9999.ebuild
new file mode 100644
index 000000000000..df9cf92b47a1
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-11.0.0.9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+LLVM_COMPONENTS=( llvm/utils/vim )
+llvm.org_set_globals
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="!sys-devel/llvm:0"
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r */
+ # some users may find it useful
+ newdoc README README.vim
+ dodoc vimrc
+}