summaryrefslogtreecommitdiff
path: root/sys-devel/llvm-common/llvm-common-9.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /sys-devel/llvm-common/llvm-common-9.0.1.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'sys-devel/llvm-common/llvm-common-9.0.1.ebuild')
-rw-r--r--sys-devel/llvm-common/llvm-common-9.0.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-9.0.1.ebuild b/sys-devel/llvm-common/llvm-common-9.0.1.ebuild
new file mode 100644
index 000000000000..a81f8f505994
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-9.0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+LLVM_COMPONENTS=( llvm/utils/vim )
+llvm.org_set_globals
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="!sys-devel/llvm:0"
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r */
+ # some users may find it useful
+ newdoc README README.vim
+ dodoc vimrc
+}