summaryrefslogtreecommitdiff
path: root/sys-devel/llvm-common/llvm-common-17.0.0_pre20230502.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-02 23:23:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-02 23:23:40 +0100
commitf20958f66a5e97c92cc44354e07e3e3089dfc23d (patch)
treefbf2993fb14c0f373d35922030b711e3fda4f864 /sys-devel/llvm-common/llvm-common-17.0.0_pre20230502.ebuild
parente805507c58bab294dddb75f6fc9b551d9d92de86 (diff)
gentoo auto-resync : 02:05:2023 - 23:23:39
Diffstat (limited to 'sys-devel/llvm-common/llvm-common-17.0.0_pre20230502.ebuild')
-rw-r--r--sys-devel/llvm-common/llvm-common-17.0.0_pre20230502.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-17.0.0_pre20230502.ebuild b/sys-devel/llvm-common/llvm-common-17.0.0_pre20230502.ebuild
new file mode 100644
index 000000000000..ce5f03ca34a5
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-17.0.0_pre20230502.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="
+ !sys-devel/llvm:0
+"
+
+LLVM_COMPONENTS=( llvm/utils/vim )
+llvm.org_set_globals
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r */
+ # some users may find it useful
+ newdoc README README.vim
+ dodoc vimrc
+}