summaryrefslogtreecommitdiff
path: root/sys-devel/llvm-common/llvm-common-17.0.0_pre20230325.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-25 12:50:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-25 12:50:15 +0000
commit71d582d27eeece574ab3d904aa3fbe7742b0e895 (patch)
treea859a9d4a94b41c113fb5bdb5c4ffe261d884970 /sys-devel/llvm-common/llvm-common-17.0.0_pre20230325.ebuild
parent0b82ae29b3034efe3e7b7f533dbcb76168544c5e (diff)
gentoo auto-resync : 25:03:2023 - 12:50:15
Diffstat (limited to 'sys-devel/llvm-common/llvm-common-17.0.0_pre20230325.ebuild')
-rw-r--r--sys-devel/llvm-common/llvm-common-17.0.0_pre20230325.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-17.0.0_pre20230325.ebuild b/sys-devel/llvm-common/llvm-common-17.0.0_pre20230325.ebuild
new file mode 100644
index 000000000000..ce5f03ca34a5
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-17.0.0_pre20230325.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="
+ !sys-devel/llvm:0
+"
+
+LLVM_COMPONENTS=( llvm/utils/vim )
+llvm.org_set_globals
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r */
+ # some users may find it useful
+ newdoc README README.vim
+ dodoc vimrc
+}