summaryrefslogtreecommitdiff
path: root/sys-devel/llvm-common/llvm-common-17.0.0.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-25 14:07:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-25 14:07:44 +0000
commit6a84e414622fd99c22318ce656a77bb2a0433fc7 (patch)
tree048f41d4a2a9c373e50bf0906c5508e6f5104fae /sys-devel/llvm-common/llvm-common-17.0.0.9999.ebuild
parenta1b20429e7e2ba1b44414459afd5a2b50788cd9c (diff)
gentoo auto-resync : 25:01:2023 - 14:07:44
Diffstat (limited to 'sys-devel/llvm-common/llvm-common-17.0.0.9999.ebuild')
-rw-r--r--sys-devel/llvm-common/llvm-common-17.0.0.9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-17.0.0.9999.ebuild b/sys-devel/llvm-common/llvm-common-17.0.0.9999.ebuild
new file mode 100644
index 000000000000..ce5f03ca34a5
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-17.0.0.9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="
+ !sys-devel/llvm:0
+"
+
+LLVM_COMPONENTS=( llvm/utils/vim )
+llvm.org_set_globals
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r */
+ # some users may find it useful
+ newdoc README README.vim
+ dodoc vimrc
+}