summaryrefslogtreecommitdiff
path: root/sys-devel/llvm-common/llvm-common-16.0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-09 06:05:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-09 06:05:12 +0100
commit431cb94e4e840d61ea21c2c2bd10e07fc27b5538 (patch)
treea5ea0afac6f3ea24f6bafd60b9199e358b1a243f /sys-devel/llvm-common/llvm-common-16.0.6.ebuild
parent94ead5b3c01213a82c9b72a2df165452421db42b (diff)
gentoo auto-resync : 09:10:2023 - 06:05:11
Diffstat (limited to 'sys-devel/llvm-common/llvm-common-16.0.6.ebuild')
-rw-r--r--sys-devel/llvm-common/llvm-common-16.0.6.ebuild36
1 files changed, 31 insertions, 5 deletions
diff --git a/sys-devel/llvm-common/llvm-common-16.0.6.ebuild b/sys-devel/llvm-common/llvm-common-16.0.6.ebuild
index ce993645101a..d1ceab13d169 100644
--- a/sys-devel/llvm-common/llvm-common-16.0.6.ebuild
+++ b/sys-devel/llvm-common/llvm-common-16.0.6.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit llvm.org
+inherit elisp-common llvm.org
DESCRIPTION="Common files shared between multiple slots of LLVM"
HOMEPAGE="https://llvm.org/"
@@ -11,18 +11,44 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv sparc x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE="emacs"
RDEPEND="
!sys-devel/llvm:0
"
+BDEPEND="
+ emacs? ( >=app-editors/emacs-23.1:* )
+"
-LLVM_COMPONENTS=( llvm/utils/vim )
+LLVM_COMPONENTS=( llvm/utils )
llvm.org_set_globals
+SITEFILE="50llvm-gentoo.el"
+BYTECOMPFLAGS="-L emacs"
+
+src_compile() {
+ default
+
+ use emacs && elisp-compile emacs/*.el
+}
+
src_install() {
insinto /usr/share/vim/vimfiles
- doins -r */
+ doins -r vim/*/
# some users may find it useful
- newdoc README README.vim
- dodoc vimrc
+ newdoc vim/README README.vim
+ dodoc vim/vimrc
+
+ if use emacs ; then
+ elisp-install llvm emacs/*.{el,elc}
+ elisp-make-site-file "${SITEFILE}" llvm
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
}