summaryrefslogtreecommitdiff
path: root/sys-devel/llvm-common/llvm-common-16.0.0_pre20221210.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-11 03:21:49 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-11 03:21:49 +0000
commitecd86b32a8f0b6be58bbb4b294ce38f1fbd7d3dc (patch)
tree11371cd9091867fc72344384665285aa7a19efd6 /sys-devel/llvm-common/llvm-common-16.0.0_pre20221210.ebuild
parentb118032096b3380de251b5de2466f5198fd2930a (diff)
gentoo auto-resync : 11:12:2022 - 03:21:49
Diffstat (limited to 'sys-devel/llvm-common/llvm-common-16.0.0_pre20221210.ebuild')
-rw-r--r--sys-devel/llvm-common/llvm-common-16.0.0_pre20221210.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-16.0.0_pre20221210.ebuild b/sys-devel/llvm-common/llvm-common-16.0.0_pre20221210.ebuild
new file mode 100644
index 000000000000..80430a85b696
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-16.0.0_pre20221210.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS="~loong"
+
+RDEPEND="
+ !sys-devel/llvm:0
+"
+
+LLVM_COMPONENTS=( llvm/utils/vim )
+llvm.org_set_globals
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r */
+ # some users may find it useful
+ newdoc README README.vim
+ dodoc vimrc
+}