summaryrefslogtreecommitdiff
path: root/sys-devel/llvm-common/llvm-common-16.0.0_pre20221010.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-11 01:37:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-11 01:37:01 +0100
commit179be85ade6b2b47bf362865b5c375969ab5ddc8 (patch)
tree073bcd19b7e1bb84acd2f683936671ee88860970 /sys-devel/llvm-common/llvm-common-16.0.0_pre20221010.ebuild
parent948f9476d6a417da6048d4291bf36b0507293d63 (diff)
gentoo auto-resync : 11:10:2022 - 01:37:00
Diffstat (limited to 'sys-devel/llvm-common/llvm-common-16.0.0_pre20221010.ebuild')
-rw-r--r--sys-devel/llvm-common/llvm-common-16.0.0_pre20221010.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-16.0.0_pre20221010.ebuild b/sys-devel/llvm-common/llvm-common-16.0.0_pre20221010.ebuild
new file mode 100644
index 000000000000..df37476f6fbc
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-16.0.0_pre20221010.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="
+ !sys-devel/llvm:0
+"
+
+LLVM_COMPONENTS=( llvm/utils/vim )
+llvm.org_set_globals
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r */
+ # some users may find it useful
+ newdoc README README.vim
+ dodoc vimrc
+}