summaryrefslogtreecommitdiff
path: root/sys-devel/llvm-common/llvm-common-15.0.6.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-29 19:21:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-29 19:21:10 +0000
commit1bfb8c3d7e00e7ff828008510f5a7568c81d8889 (patch)
treea22ec1622549507f5333dca366a3b1f3e9af1dca /sys-devel/llvm-common/llvm-common-15.0.6.9999.ebuild
parent82020bf7ff936f52f6f1efc646ae374e46b5ed36 (diff)
gentoo auto-resync : 29:11:2022 - 19:21:10
Diffstat (limited to 'sys-devel/llvm-common/llvm-common-15.0.6.9999.ebuild')
-rw-r--r--sys-devel/llvm-common/llvm-common-15.0.6.9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-15.0.6.9999.ebuild b/sys-devel/llvm-common/llvm-common-15.0.6.9999.ebuild
new file mode 100644
index 000000000000..df37476f6fbc
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-15.0.6.9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="
+ !sys-devel/llvm:0
+"
+
+LLVM_COMPONENTS=( llvm/utils/vim )
+llvm.org_set_globals
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r */
+ # some users may find it useful
+ newdoc README README.vim
+ dodoc vimrc
+}