summaryrefslogtreecommitdiff
path: root/sys-devel/lld/lld-10.0.0.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:19:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-14 23:22:23 +0100
commit4b19be30aa626b327c885dae62c559ec0e9fb935 (patch)
tree76e74807bc479502e13866b581b6bf86734ec634 /sys-devel/lld/lld-10.0.0.9999.ebuild
parent30d6f67c98d149508509d5e86f176d558793acc0 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'sys-devel/lld/lld-10.0.0.9999.ebuild')
-rw-r--r--sys-devel/lld/lld-10.0.0.9999.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-devel/lld/lld-10.0.0.9999.ebuild b/sys-devel/lld/lld-10.0.0.9999.ebuild
index 2469a9bd7046..9d1c88d828d3 100644
--- a/sys-devel/lld/lld-10.0.0.9999.ebuild
+++ b/sys-devel/lld/lld-10.0.0.9999.ebuild
@@ -55,7 +55,7 @@ src_unpack() {
src_configure() {
local mycmakeargs=(
- -DBUILD_SHARED_LIBS=ON
+ -DBUILD_SHARED_LIBS=OFF
-DLLVM_INCLUDE_TESTS=$(usex test)
)
@@ -73,3 +73,9 @@ src_test() {
local -x LIT_PRESERVES_TMP=1
cmake-utils_src_make check-lld
}
+
+src_install() {
+ cmake-utils_src_install
+ # LLD has no shared libraries, so strip it all for the time being
+ rm -r "${ED}"/usr/{include,lib*} || die
+}