summaryrefslogtreecommitdiff
path: root/sys-devel/kgcc64/kgcc64-4.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /sys-devel/kgcc64/kgcc64-4.1.2.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'sys-devel/kgcc64/kgcc64-4.1.2.ebuild')
-rw-r--r--sys-devel/kgcc64/kgcc64-4.1.2.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/sys-devel/kgcc64/kgcc64-4.1.2.ebuild b/sys-devel/kgcc64/kgcc64-4.1.2.ebuild
deleted file mode 100644
index a89d7c2bc1c7..000000000000
--- a/sys-devel/kgcc64/kgcc64-4.1.2.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-case ${CHOST} in
- hppa*) CTARGET=hppa64-${CHOST#*-};;
- mips*) CTARGET=${CHOST/mips/mips64};;
- powerpc*) CTARGET=${CHOST/powerpc/powerpc64};;
- s390*) CTARGET=${CHOST/s390/s390x};;
- sparc*) CTARGET=${CHOST/sparc/sparc64};;
- i?86*) CTARGET=x86_64-${CHOST#*-};;
-esac
-export CTARGET
-TOOLCHAIN_ALLOWED_LANGS="c"
-GCC_TARGET_NO_MULTILIB=true
-
-PATCH_VER="1.0.1"
-
-inherit eutils toolchain
-
-DESCRIPTION="64bit kernel compiler"
-
-KEYWORDS="-* hppa ~mips ~s390"
-
-# unlike every other target, hppa has not unified the 32/64 bit
-# ports in binutils yet
-DEPEND="hppa? ( sys-devel/binutils-hppa64 )"
-
-src_prepare() {
- toolchain_src_prepare
- # Fix cross-compiling
- epatch "${FILESDIR}"/4.1.0/gcc-4.1.0-cross-compile.patch
-}
-
-pkg_postinst() {
- toolchain_pkg_postinst
-
- cd "${ROOT}"/usr/bin
- local x
- for x in gcc cpp ; do
- cat <<-EOF >${CTARGET%%-*}-linux-${x}
- #!/bin/sh
- exec ${CTARGET}-${x} "\$@"
- EOF
- chmod a+rx ${CTARGET%%-*}-linux-${x}
- done
-}