summaryrefslogtreecommitdiff
path: root/sys-devel/kgcc64/kgcc64-13.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-29 04:38:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-29 04:38:41 +0100
commitd5c5aa9b48bd6a821f5e0a1a98474ac35fb21360 (patch)
tree9de3699cbe327fb5dd93a6ec37b895f9fdb94494 /sys-devel/kgcc64/kgcc64-13.2.0.ebuild
parentc6a12f3c8604a9269cfb82d666fc716df0e67792 (diff)
gentoo auto-resync : 29:07:2023 - 04:38:40
Diffstat (limited to 'sys-devel/kgcc64/kgcc64-13.2.0.ebuild')
-rw-r--r--sys-devel/kgcc64/kgcc64-13.2.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-devel/kgcc64/kgcc64-13.2.0.ebuild b/sys-devel/kgcc64/kgcc64-13.2.0.ebuild
new file mode 100644
index 000000000000..419eecdd613b
--- /dev/null
+++ b/sys-devel/kgcc64/kgcc64-13.2.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+case ${CHOST} in
+ hppa*) CTARGET=hppa64-${CHOST#*-};;
+ mips*) CTARGET=${CHOST/mips/mips64};;
+ powerpc*) CTARGET=${CHOST/powerpc/powerpc64};;
+ s390*) CTARGET=${CHOST/s390/s390x};;
+ sparc*) CTARGET=${CHOST/sparc/sparc64};;
+ i?86*) CTARGET=x86_64-${CHOST#*-};;
+esac
+export CTARGET
+TOOLCHAIN_ALLOWED_LANGS="c"
+TOOLCHAIN_PATCH_DEV="sam"
+PATCH_VER="3"
+PATCH_GCC_VER="13.2.0"
+MUSL_VER="2"
+MUSL_GCC_VER="13.2.0"
+GCC_TARGET_NO_MULTILIB=true
+inherit toolchain
+
+DESCRIPTION="64bit kernel compiler"
+
+# Works on hppa and mips; all other archs, refer to bug #228115
+KEYWORDS="~hppa"
+
+# unlike every other target, hppa has not unified the 32/64 bit
+# ports in binutils yet
+BDEPEND="hppa? ( sys-devel/binutils-hppa64 )"
+
+pkg_postinst() {
+ toolchain_pkg_postinst
+
+ cd "${ROOT}"/usr/bin
+ local x
+ for x in gcc cpp ; do
+ cat <<-EOF >${CTARGET%%-*}-linux-${x}
+ #!/bin/sh
+ exec ${CTARGET}-${x} "\$@"
+ EOF
+ chmod a+rx ${CTARGET%%-*}-linux-${x}
+ done
+}