summaryrefslogtreecommitdiff
path: root/sys-devel/kgcc64/kgcc64-12.3.1_p20230825.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-27 03:58:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-27 03:58:56 +0100
commiteb90394012a5d0ba3c13992fb861eb3387728c92 (patch)
treeef1098f5f74a16b29ec0dcf3cb0277809903d37c /sys-devel/kgcc64/kgcc64-12.3.1_p20230825.ebuild
parentd76b6613e545057331e9273ddd21e68d28d9e402 (diff)
gentoo auto-resync : 27:08:2023 - 03:58:56
Diffstat (limited to 'sys-devel/kgcc64/kgcc64-12.3.1_p20230825.ebuild')
-rw-r--r--sys-devel/kgcc64/kgcc64-12.3.1_p20230825.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-devel/kgcc64/kgcc64-12.3.1_p20230825.ebuild b/sys-devel/kgcc64/kgcc64-12.3.1_p20230825.ebuild
new file mode 100644
index 000000000000..886da7c53eb0
--- /dev/null
+++ b/sys-devel/kgcc64/kgcc64-12.3.1_p20230825.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+case ${CHOST} in
+ hppa*) CTARGET=hppa64-${CHOST#*-};;
+ mips*) CTARGET=${CHOST/mips/mips64};;
+ powerpc*) CTARGET=${CHOST/powerpc/powerpc64};;
+ s390*) CTARGET=${CHOST/s390/s390x};;
+ sparc*) CTARGET=${CHOST/sparc/sparc64};;
+ i?86*) CTARGET=x86_64-${CHOST#*-};;
+esac
+export CTARGET
+TOOLCHAIN_ALLOWED_LANGS="c"
+TOOLCHAIN_PATCH_DEV="sam"
+PATCH_VER="2"
+PATCH_GCC_VER="12.3.0"
+MUSL_VER="1"
+MUSL_GCC_VER="12.3.0"
+GCC_TARGET_NO_MULTILIB=true
+inherit toolchain
+
+DESCRIPTION="64bit kernel compiler"
+
+# Works on hppa and mips; all other archs, refer to bug #228115
+KEYWORDS="~hppa"
+
+# unlike every other target, hppa has not unified the 32/64 bit
+# ports in binutils yet
+BDEPEND="hppa? ( sys-devel/binutils-hppa64 )"
+
+src_prepare() {
+ toolchain_src_prepare
+ eapply "${FILESDIR}"/gcc-12.3-ccache-ICE.patch
+}
+
+pkg_postinst() {
+ toolchain_pkg_postinst
+
+ cd "${ROOT}"/usr/bin
+ local x
+ for x in gcc cpp ; do
+ cat <<-EOF >${CTARGET%%-*}-linux-${x}
+ #!/bin/sh
+ exec ${CTARGET}-${x} "\$@"
+ EOF
+ chmod a+rx ${CTARGET%%-*}-linux-${x}
+ done
+}