summaryrefslogtreecommitdiff
path: root/sys-devel/gdb/gdb-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-03 03:09:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-03 03:09:13 +0000
commitf80acd7c227d742fc13a5e8a85c96e59c0544d98 (patch)
treef4978d4dd601793065e3b7db1fa8f3b303d1b7b1 /sys-devel/gdb/gdb-9999.ebuild
parentc107831b9ebfe892c139cdb68d747eea369d8588 (diff)
gentoo auto-resync : 03:02:2023 - 03:09:13
Diffstat (limited to 'sys-devel/gdb/gdb-9999.ebuild')
-rw-r--r--sys-devel/gdb/gdb-9999.ebuild20
1 files changed, 14 insertions, 6 deletions
diff --git a/sys-devel/gdb/gdb-9999.ebuild b/sys-devel/gdb/gdb-9999.ebuild
index 9eb29deacc90..9e1fdd605935 100644
--- a/sys-devel/gdb/gdb-9999.ebuild
+++ b/sys-devel/gdb/gdb-9999.ebuild
@@ -26,7 +26,7 @@ case ${PV} in
inherit git-r3
SRC_URI=""
;;
- *.*.50_p2???????| *.*.90_p2???????)
+ *.*.50_p2???????|*.*.90_p2???????)
# Weekly snapshots
MY_PV="${PV/_p/.}"
SRC_URI="
@@ -35,12 +35,22 @@ case ${PV} in
"
S="${WORKDIR}/${PN}-${MY_PV}"
;;
+ *.*.9?)
+ # Prereleases
+ MY_PV="${PV/_p/.}"
+ SRC_URI="
+ https://sourceware.org/pub/gdb/snapshots/branch/gdb-${MY_PV}.tar.xz
+ "
+ S="${WORKDIR}/${PN}-${MY_PV}"
+ ;;
*)
# Normal upstream release
SRC_URI="
mirror://gnu/gdb/${P}.tar.xz
https://sourceware.org/pub/gdb/releases/${P}.tar.xz
"
+
+ #KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
;;
esac
@@ -56,14 +66,12 @@ SRC_URI="
LICENSE="GPL-3+ LGPL-2.1+"
SLOT="0"
-
-if [[ ${PV} != 9999* ]] ; then
+IUSE="cet guile lzma multitarget nls +python +server sim source-highlight test vanilla xml xxhash zstd"
+# TODO: Drop once 13 is released
+if [[ ${PV} != 9999 ]] ; then
# for testing on loong only
- #KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
KEYWORDS="~loong"
fi
-
-IUSE="cet guile lzma multitarget nls +python +server sim source-highlight test vanilla xml xxhash zstd"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RESTRICT="!test? ( test )"