summaryrefslogtreecommitdiff
path: root/sys-devel/gdb/gdb-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-30 03:23:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-30 03:23:47 +0100
commitd70b0f920e70eb6f0a26d9ed3767e27a73c74678 (patch)
tree0de1772059756dc015bac48ac506bff5409c802e /sys-devel/gdb/gdb-9999.ebuild
parent15a738a098c486b6ec6d624050dd98826f9c2d3f (diff)
gentoo auto-resync : 30:09:2022 - 03:23:47
Diffstat (limited to 'sys-devel/gdb/gdb-9999.ebuild')
-rw-r--r--sys-devel/gdb/gdb-9999.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/sys-devel/gdb/gdb-9999.ebuild b/sys-devel/gdb/gdb-9999.ebuild
index 9a3b277f6524..6bf40e5071f6 100644
--- a/sys-devel/gdb/gdb-9999.ebuild
+++ b/sys-devel/gdb/gdb-9999.ebuild
@@ -50,7 +50,7 @@ if [[ ${PV} != 9999* ]] ; then
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
-IUSE="cet guile lzma multitarget nls +python +server source-highlight test vanilla xml xxhash"
+IUSE="cet guile lzma multitarget nls +python +server source-highlight test vanilla xml xxhash zstd"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
# In fact, gdb's test suite needs some work to get passing.
@@ -77,12 +77,9 @@ RDEPEND="
python? ( ${PYTHON_DEPS} )
guile? ( >=dev-scheme/guile-2.0 )
xml? ( dev-libs/expat )
- source-highlight? (
- dev-util/source-highlight
- )
- xxhash? (
- dev-libs/xxhash
- )
+ source-highlight? ( dev-util/source-highlight )
+ xxhash? ( dev-libs/xxhash )
+ zstd? ( app-arch/zstd:= )
"
DEPEND="${RDEPEND}"
BDEPEND="
@@ -204,6 +201,7 @@ src_configure() {
$(use_with python python "${EPYTHON}")
$(use_with xxhash)
$(use_with guile)
+ $(use_with zstd)
)
if use sparc-solaris || use x86-solaris ; then