summaryrefslogtreecommitdiff
path: root/sys-devel/gdb/gdb-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-14 03:28:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-14 03:28:58 +0000
commitc73b611d606bc14760bad8592f5bfec28c9b1079 (patch)
tree6da7421d10ecff1c38c3774f9a9eed715711fd7c /sys-devel/gdb/gdb-9999.ebuild
parentb9d995791a762215ef1ced2cc1a47b8d3c2cff1a (diff)
gentoo auto-resync : 14:12:2022 - 03:28:57
Diffstat (limited to 'sys-devel/gdb/gdb-9999.ebuild')
-rw-r--r--sys-devel/gdb/gdb-9999.ebuild28
1 files changed, 17 insertions, 11 deletions
diff --git a/sys-devel/gdb/gdb-9999.ebuild b/sys-devel/gdb/gdb-9999.ebuild
index 940f57beb14b..22ec6a50951e 100644
--- a/sys-devel/gdb/gdb-9999.ebuild
+++ b/sys-devel/gdb/gdb-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( python3_{8..11} )
inherit flag-o-matic python-single-r1 strip-linguas toolchain-funcs
@@ -23,9 +23,11 @@ case ${PV} in
inherit git-r3
SRC_URI=""
;;
- *.*.50.2???????)
+ *.*.50_p2???????)
# weekly snapshots
- SRC_URI="ftp://sourceware.org/pub/gdb/snapshots/current/gdb-weekly-${PV}.tar.xz"
+ MY_PV="${PV/_p/.}"
+ SRC_URI="https://sourceware.org/pub/gdb/snapshots/current/gdb-weekly-${MY_PV}.tar.xz"
+ S="${WORKDIR}/${PN}-${MY_PV}"
;;
*)
# Normal upstream release
@@ -34,23 +36,22 @@ case ${PV} in
;;
esac
-PATCH_VER=""
-PATCH_DEV=""
DESCRIPTION="GNU debugger"
HOMEPAGE="https://sourceware.org/gdb/"
SRC_URI="${SRC_URI}
${PATCH_DEV:+https://dev.gentoo.org/~${PATCH_DEV}/distfiles/${P}-patches-${PATCH_VER}.tar.xz}
- ${PATCH_VER:+mirror://gentoo/${P}-patches-${PATCH_VER}.tar.xz}
-"
+ ${PATCH_VER:+mirror://gentoo/${P}-patches-${PATCH_VER}.tar.xz}"
LICENSE="GPL-3+ LGPL-2.1+"
SLOT="0"
if [[ ${PV} != 9999* ]] ; then
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ # for testing on loong only
+ #KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~loong"
fi
-IUSE="cet guile lzma multitarget nls +python +server source-highlight test vanilla xml xxhash zstd"
+IUSE="cet guile lzma multitarget nls +python +server sim source-highlight test vanilla xml xxhash zstd"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
# In fact, gdb's test suite needs some work to get passing.
@@ -77,8 +78,12 @@ RDEPEND="
python? ( ${PYTHON_DEPS} )
guile? ( >=dev-scheme/guile-2.0 )
xml? ( dev-libs/expat )
- source-highlight? ( dev-util/source-highlight )
- xxhash? ( dev-libs/xxhash )
+ source-highlight? (
+ dev-util/source-highlight
+ )
+ xxhash? (
+ dev-libs/xxhash
+ )
zstd? ( app-arch/zstd:= )
"
DEPEND="${RDEPEND}"
@@ -196,6 +201,7 @@ src_configure() {
$(use_with xml expat)
$(use_with lzma)
$(use_enable nls)
+ $(use_enable sim)
$(use_enable source-highlight)
$(use multitarget && echo --enable-targets=all)
$(use_with python python "${EPYTHON}")