summaryrefslogtreecommitdiff
path: root/sys-devel/gdb/gdb-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
commit53cba99042fa967e2a93da9f8db806fe2d035543 (patch)
tree9780d3b87dfc6bdebc6b7b7d15af1ecb813c6853 /sys-devel/gdb/gdb-9999.ebuild
parent71deace00d1a2b091313fe137ab7092418c6f87c (diff)
gentoo resync : 17.02.2020
Diffstat (limited to 'sys-devel/gdb/gdb-9999.ebuild')
-rw-r--r--sys-devel/gdb/gdb-9999.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sys-devel/gdb/gdb-9999.ebuild b/sys-devel/gdb/gdb-9999.ebuild
index 0917eed36ce3..06bc04042454 100644
--- a/sys-devel/gdb/gdb-9999.ebuild
+++ b/sys-devel/gdb/gdb-9999.ebuild
@@ -46,7 +46,7 @@ SLOT="0"
if [[ ${PV} != 9999* ]] ; then
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
-IUSE="+client lzma multitarget nls +python +server source-highlight test vanilla xml"
+IUSE="+client lzma multitarget nls +python +server source-highlight test vanilla xml xxhash"
REQUIRED_USE="
python? ( ${PYTHON_REQUIRED_USE} )
|| ( client server )
@@ -65,7 +65,7 @@ RDEPEND="
client? (
dev-libs/mpfr:0=
>=sys-libs/ncurses-5.2-r2:0=
- sys-libs/readline:0=
+ >=sys-libs/readline-7:0=
lzma? ( app-arch/xz-utils )
python? ( ${PYTHON_DEPS} )
xml? ( dev-libs/expat )
@@ -74,6 +74,9 @@ RDEPEND="
source-highlight? (
dev-util/source-highlight
)
+ xxhash? (
+ dev-libs/xxhash
+ )
"
DEPEND="${RDEPEND}"
BDEPEND="
@@ -169,6 +172,7 @@ src_configure() {
$(use_enable source-highlight)
$(use multitarget && echo --enable-targets=all)
$(use_with python python "${EPYTHON}")
+ $(use_with xxhash)
)
fi
if use sparc-solaris || use x86-solaris ; then