summaryrefslogtreecommitdiff
path: root/sys-devel/gdb-apple/gdb-apple-1752.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
commita4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (patch)
tree852c90a4bf354c30ea66504f70bfab5401fba18d /sys-devel/gdb-apple/gdb-apple-1752.ebuild
parent5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (diff)
gentoo resync : 28.04.2018
Diffstat (limited to 'sys-devel/gdb-apple/gdb-apple-1752.ebuild')
-rw-r--r--sys-devel/gdb-apple/gdb-apple-1752.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/sys-devel/gdb-apple/gdb-apple-1752.ebuild b/sys-devel/gdb-apple/gdb-apple-1752.ebuild
index 6a6d6a5c511c..f374628fb7d5 100644
--- a/sys-devel/gdb-apple/gdb-apple-1752.ebuild
+++ b/sys-devel/gdb-apple/gdb-apple-1752.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=6
inherit eutils flag-o-matic
@@ -24,14 +24,16 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/gdb-${APPLE_PV}/src
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-no-global-gdbinit.patch
- epatch "${FILESDIR}"/${PN}-768-texinfo.patch
- epatch "${FILESDIR}"/${PN}-1518-darwin8-9.patch
- epatch "${FILESDIR}"/${PN}-1705-darwin8-10.patch
- [[ ${CHOST} == *-darwin8 ]] && epatch "${FILESDIR}"/${PN}-1518-darwin8.patch
+PATCHES=(
+ "${FILESDIR}"/${PN}-no-global-gdbinit.patch
+ "${FILESDIR}"/${PN}-768-texinfo.patch
+ "${FILESDIR}"/${PN}-1518-darwin8-9.patch
+ "${FILESDIR}"/${PN}-1705-darwin8-10.patch
+)
- eapply_user
+src_prepare() {
+ default
+ [[ ${CHOST} == *-darwin8 ]] && eapply "${FILESDIR}"/${PN}-1518-darwin8.patch
}
src_configure() {